*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-mobilephone / lightblue / lightblue-0.4-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7 inherit distutils-r1
8
9 DESCRIPTION="API for Python which provides simple access to Bluetooth operations"
10 HOMEPAGE="http://lightblue.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="examples"
17
18 DEPEND="
19         >=dev-libs/openobex-1.3
20         >=dev-python/pybluez-0.9[${PYTHON_USEDEP}]
21 "
22 RDEPEND="${DEPEND}"
23
24 python_install_all() {
25         use examples && local EXAMPLES=( examples/. )
26         distutils-r1_python_install_all
27 }