*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-mobilephone / adb-sync / adb-sync-0_p20181127-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 PYTHON_COMPAT=( python2_7 python3_{6,7} )
6
7 inherit python-single-r1
8
9 COMMIT=b0a2a10
10
11 DESCRIPTION="Synchronize files between a PC and an Android device using ADB"
12 HOMEPAGE="https://github.com/google/adb-sync"
13 SRC_URI="https://github.com/google/adb-sync/tarball/${COMMIT} -> ${P}.tar.gz"
14
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE="+channel"
19 REQUIRED_USE=${PYTHON_REQUIRED_USE}
20
21 RDEPEND="${PYTHON_DEPS}
22         dev-util/android-tools
23         channel? ( net-misc/socat )"
24 DEPEND=""
25
26 S="${WORKDIR}/google-adb-sync-${COMMIT}"
27
28 src_install() {
29         dodoc README.md
30         python_doscript adb-sync
31         use channel && dobin adb-channel
32 }