216503f89eb41d336a8e4fb022d10480ed3a889e
[gentoo.git] / app-misc / zisofs-tools / zisofs-tools-1.0.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit flag-o-matic
6
7 DESCRIPTION="User utilities for zisofs"
8 HOMEPAGE="https://www.kernel.org/pub/linux/utils/fs/zisofs/"
9 SRC_URI="mirror://gentoo/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
14 IUSE="static"
15
16 RDEPEND=">=sys-libs/zlib-1.1.4:0="
17 DEPEND="${RDEPEND}"
18
19 src_configure() {
20         use static && append-ldflags -static
21         default
22 }
23
24 src_install() {
25         emake INSTALLROOT="${D}" install
26         einstalldocs
27 }