aa4bd4bb42eaab20015e1f30ff6400f7711011f1
[gentoo.git] / app-misc / ddccontrol-db / ddccontrol-db-20061014_p20121105.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools
7
8 DESCRIPTION="DDCControl monitor database"
9 HOMEPAGE="http://ddccontrol.sourceforge.net/"
10 COMMIT_ID="130da80af5cd5d2897ffeed63362262262c6944f"
11 SRC_URI="https://github.com/ddccontrol/ddccontrol-db/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE="nls"
17
18 S=${WORKDIR}/${PN}-${COMMIT_ID}
19
20 RDEPEND="nls? ( sys-devel/gettext )"
21 DEPEND="${RDEPEND}
22                 dev-util/intltool
23                 dev-perl/XML-Parser"
24
25 src_prepare(){
26         touch db/options.xml.h ABOUT-NLS config.rpath || die
27         eautoreconf
28 }
29
30 src_configure() {
31         econf $(use_enable nls)
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install
36         dodoc AUTHORS ChangeLog NEWS README
37 }