*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-misc / chkcrontab / chkcrontab-1.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A tool to detect crontab errors"
11 HOMEPAGE="https://github.com/lyda/chkcrontab"
12 SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 python_test() {
21         esetup.py test || die
22 }
23
24 python_install_all() {
25         doman doc/${PN}.1
26         distutils-r1_python_install_all
27 }