Drop arm-linux keyword from tree.
[gentoo.git] / app-misc / c_rehash / c_rehash-1.7-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="c_rehash script from OpenSSL"
7 HOMEPAGE="https://www.openssl.org/ https://github.com/pld-linux/openssl/"
8 SRC_URI="https://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/openssl/openssl-c_rehash.sh?rev=${PV} -> openssl-c_rehash.sh.${PV}"
9
10 LICENSE="openssl"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
13 IUSE=""
14
15 RDEPEND="!<dev-libs/openssl-1.0.2d-r1:0"
16 DEPEND="${RDEPEND}"
17
18 S=${WORKDIR}
19
20 src_prepare() {
21         SSL_CNF_DIR="/etc/ssl"
22         sed \
23                 -e "/^DIR=/s:=.*:=${EPREFIX}${SSL_CNF_DIR}:" \
24                 -e "s:SSL_CMD=/usr:SSL_CMD=${EPREFIX}/usr:" \
25                 "${DISTDIR}"/openssl-c_rehash.sh.${PV} \
26                 > "${WORKDIR}"/c_rehash || die #416717
27 }
28
29 src_install() {
30         dobin "${WORKDIR}"/c_rehash
31 }