sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / app-laptop / thinkfan / thinkfan-1.0.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake-utils readme.gentoo-r1
7
8 DESCRIPTION="simple fan control program for thinkpads"
9 HOMEPAGE="http://thinkfan.sourceforge.net"
10 SRC_URI="https://github.com/vmatare/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="atasmart nvidia +yaml"
16
17 DEPEND="atasmart? ( dev-libs/libatasmart )
18         yaml? ( dev-cpp/yaml-cpp )"
19 RDEPEND="${DEPEND}
20         nvidia? ( x11-drivers/nvidia-drivers )"
21
22 DOC_CONTENTS="
23         Please read the documentation and copy an appropriate
24         file to /etc/thinkfan.conf.
25 "
26
27 src_configure() {
28         local mycmakeargs+=(
29                 -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
30                 -DUSE_NVML="$(usex nvidia)"
31                 -DUSE_ATASMART="$(usex atasmart)"
32                 -DUSE_YAML="$(usex yaml)"
33         )
34
35         cmake-utils_src_configure
36 }
37
38 src_install() {
39         cmake-utils_src_install
40
41         readme.gentoo_create_doc
42 }