*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / app-i18n / libhangul / libhangul-0.1.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 DESCRIPTION="Library for hangul input method logic, hanja dictionary"
7 HOMEPAGE="https://github.com/libhangul/libhangul"
8 SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
9
10 LICENSE="LGPL-2.1+"
11 SLOT="0/1"
12 KEYWORDS="amd64 ppc ppc64 x86"
13 IUSE="nls static-libs test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="virtual/libiconv
17         nls? ( virtual/libintl )"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig
20         nls? ( sys-devel/gettext )
21         test? ( dev-libs/check )"
22
23 src_configure() {
24         econf \
25                 $(use_enable nls) \
26                 $(use_enable static-libs static)
27 }
28
29 src_test() {
30         emake -C test check
31 }
32
33 src_install() {
34         default
35         find "${ED}" -name '*.la' -delete || die
36 }