*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-emulation / glean / glean-1.10.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Simple program to write static config from config-drive"
11 HOMEPAGE="https://github.com/openstack-infra/glean"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         dev-python/pbr[${PYTHON_USEDEP}]"
22 RDEPEND="${DEPEND}"
23
24 src_install() {
25         distutils-r1_src_install
26         newinitd "${FILESDIR}/${PN}.initd" ${PN}
27 }