a5a08c013e87631a96b5ad9bb984bd55430a3042
[gentoo.git] / app-emulation / ganeti-instance-debootstrap / ganeti-instance-debootstrap-0.16.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools
6
7 DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
8 HOMEPAGE="http://www.ganeti.org/"
9 SRC_URI="http://downloads.ganeti.org/instance-debootstrap/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14
15 RDEPEND="
16         ${DEPEND}
17         >=sys-apps/coreutils-6.10-r1
18         app-arch/dpkg
19         app-arch/dump
20         app-emulation/ganeti
21         dev-util/debootstrap
22         sys-apps/util-linux
23         sys-fs/e2fsprogs
24         sys-fs/multipath-tools
25 "
26
27 src_prepare() {
28         default
29
30         sed -i -e 's|AC_MSG_ERROR|AC_MSG_WARN|g' configure.ac || die
31         sed -i -e 's|COPYING||g' Makefile.am || die
32
33         eautoreconf
34 }
35
36 src_configure() {
37         econf --docdir=/usr/share/doc/${P}
38 }
39
40 src_install() {
41         default
42
43         insinto /etc/ganeti/instance-debootstrap/hooks
44         doins examples/hooks/*
45 }