sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / app-emulation / dlx / dlx-1.5.20.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="DLX Simulator"
9 HOMEPAGE="https://www.davidviner.com/dlx"
10 SRC_URI="https://www.davidviner.com/zip/dlx/dlx.zip -> ${P}.zip"
11 S=${WORKDIR}/dlx
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 DEPEND="app-arch/unzip"
19
20 src_compile() {
21         # CXX not used
22         emake CC="$(tc-getCC)" LINK="$(tc-getCC)" \
23                 CFLAGS="${CFLAGS} ${CPPFLAGS}" \
24                 LFLAGS="${CFLAGS} ${LDFLAGS}"
25 }
26
27 src_install() {
28         dobin masm mon dasm
29         dodoc README.txt MANUAL.TXT
30 }