*/*: Bump copyright on files touched this year
[gentoo.git] / app-emacs / yc / yc-4.0.13.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit elisp toolchain-funcs
7
8 DESCRIPTION="Yet another Canna client on Emacsen"
9 HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
10 SRC_URI="http://www.ceres.dti.ne.jp/~knak/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ppc x86"
15 IUSE=""
16
17 RDEPEND="app-i18n/canna"
18
19 SITEFILE="50${PN}-gentoo.el"
20
21 src_prepare() {
22         sed -i '/$(CC)/s/ -o / $(CFLAGS) $(LDFLAGS) -o /' Makefile
23
24         default
25 }
26
27 src_compile() {
28         emake CC="$(tc-getCC)"
29 }
30
31 src_install() {
32         elisp_src_install
33
34         dobin icanna
35         dodoc "${FILESDIR}"/sample.{dot.emacs,hosts.canna}
36 }
37
38 pkg_postinst() {
39         elisp_pkg_postinst
40
41         elog "See the sample.dot.emacs in ${EPREFIX}/usr/share/doc/${PF}."
42         elog
43         elog "And If you use unix domain socket for connecting the canna server,"
44         elog "please confirm that there's *no* following line in your ~/.emacs:"
45         elog '  (setq yc-server-host "localhost")'
46         elog
47         elog "If you use inet domain socket for connecting the canna server,"
48         elog "please modify as following in ${EPREFIX}/etc/conf.d/canna:"
49         elog '  CANNASERVER_OPTS="-inet"'
50         elog
51         elog "And create ${EPREFIX}/etc/hosts.canna."
52         elog "See the sample.hosts.canna in ${EPREFIX}/usr/share/doc/${PF}."
53 }