707dca017645135ebc30a31729df1e998b012b8e
[gentoo.git] / app-emacs / nxml-gentoo-schemas / nxml-gentoo-schemas-20200303.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
9 HOMEPAGE="https://gitweb.gentoo.org/proj/nxml-gentoo-schemas.git/"
10 SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
11
12 LICENSE="HPND"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ~ppc64 ~sparc ~x86"
15
16 SITEFILE="60${PN}-gentoo.el"
17
18 src_compile() { :; }
19
20 src_install() {
21         insinto "${SITEETC}/${PN}"
22         doins schemas.xml *.rnc
23         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
24 }