app-emacs/lyskom-elisp-client: New snapshot.
[gentoo.git] / app-emacs / lyskom-elisp-client / lyskom-elisp-client-0.48_p20200226.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp readme.gentoo-r1
7
8 DESCRIPTION="Elisp client for the LysKOM conference system"
9 HOMEPAGE="http://www.lysator.liu.se/lyskom/klienter/emacslisp/index.en.html"
10 # snapshot of git://git.lysator.liu.se/${PN}/${PN}.git
11 SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~sparc ~x86"
16 IUSE="l10n_sv"
17
18 S="${WORKDIR}/${PN}"
19 ELISP_PATCHES="${PN}-0.48_p20161231-no-git.patch"
20 SITEFILE="50${PN}-gentoo.el"
21
22 src_prepare() {
23         elisp_src_prepare
24         local d=${PV#*_p}
25         sed -i "s/@@DATE@@/${d:0:4}-${d:4:2}-${d:6:2}/" src/Makefile || die
26 }
27
28 src_compile() {
29         emake -C src EMACS=emacs
30         # Info page is in Swedish only
31         use l10n_sv && emake -C doc elisp-client
32 }
33
34 src_install() {
35         elisp-install ${PN} src/lyskom.{el,elc}
36         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
37         dodoc src/{ChangeLog*,README,TODO} doc/NEWS*
38         use l10n_sv && doinfo doc/elisp-client
39
40         DOC_CONTENTS="If you prefer an English language environment, add the
41                 following line to your ~/.emacs file:
42                 \n\t(setq-default kom-default-language 'en)"
43         readme.gentoo_create_doc
44 }