*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-crypt / certbot / certbot-1.0.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=(python{2_7,3_6,3_7})
6
7 if [[ ${PV} == 9999* ]]; then
8         EGIT_REPO_URI="https://github.com/certbot/certbot.git"
9         inherit git-r3
10 else
11         SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12         KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
13 fi
14 S=${WORKDIR}/${P}/${PN}
15
16 inherit distutils-r1
17
18 DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
19 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
20
21 LICENSE="Apache-2.0"
22 SLOT="0"
23 IUSE="test"
24 RESTRICT="!test? ( test )"
25
26 CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
27 RDEPEND="
28         ${CDEPEND}
29         >=app-crypt/acme-0.40.0[${PYTHON_USEDEP}]
30         >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
31         dev-python/configobj[${PYTHON_USEDEP}]
32         >=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
33         >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
34         >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
35         dev-python/mock[${PYTHON_USEDEP}]
36         >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
37         dev-python/pyrfc3339[${PYTHON_USEDEP}]
38         dev-python/pytz[${PYTHON_USEDEP}]
39         dev-python/zope-component[${PYTHON_USEDEP}]
40         dev-python/zope-interface[${PYTHON_USEDEP}]"
41 DEPEND="
42         ${CDEPEND}
43         test? (
44                 dev-python/pytest[${PYTHON_USEDEP}]
45         )"
46
47 python_test() {
48         # acme is not installed, removing it here is fine, the dir just confuses tests
49         rm -R ../acme
50         pytest -vv ${PN} || die
51 }