*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-crypt / certbot-dns-nsone / certbot-dns-nsone-0.39.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=(python{2_7,3_6})
6
7 if [[ ${PV} == 9999* ]]; then
8         EGIT_REPO_URI="https://github.com/certbot/certbot.git"
9         inherit git-r3
10         S=${WORKDIR}/${P}/${PN}
11 else
12         SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~amd64 ~x86"
14         S=${WORKDIR}/certbot-${PV}/${PN}
15 fi
16
17 inherit distutils-r1
18
19 DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
20 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
21
22 LICENSE="Apache-2.0"
23 SLOT="0"
24 IUSE=""
25
26 CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
27 RDEPEND="${CDEPEND}
28         =app-crypt/certbot-${PV%.*}*[${PYTHON_USEDEP}]
29         =app-crypt/acme-${PV%.*}*[${PYTHON_USEDEP}]
30         dev-python/mock[${PYTHON_USEDEP}]
31         dev-python/zope-interface[${PYTHON_USEDEP}]
32         dev-python/dns-lexicon[${PYTHON_USEDEP}]"
33 DEPEND="${CDEPEND}"