*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-crypt / certbot-apache / certbot-apache-0.39.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=(python{2_7,3_6,3_7})
6
7 if [[ ${PV} == 9999* ]]; then
8         EGIT_REPO_URI="https://github.com/certbot/certbot.git"
9         inherit git-r3
10         S=${WORKDIR}/${P}/${PN}
11 else
12         SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
13         KEYWORDS="amd64 ~arm64 x86"
14         S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
15 fi
16
17 inherit distutils-r1
18
19 DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
20 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
21
22 LICENSE="Apache-2.0"
23 SLOT="0"
24 IUSE="test"
25 RESTRICT="!test? ( test )"
26
27 RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
28         >=app-crypt/certbot-0.39.0[${PYTHON_USEDEP}]
29         dev-python/mock[${PYTHON_USEDEP}]
30         dev-python/python-augeas[${PYTHON_USEDEP}]
31         dev-python/zope-component[${PYTHON_USEDEP}]
32         dev-python/zope-interface[${PYTHON_USEDEP}]"
33 DEPEND="test? ( ${RDEPEND}
34         dev-python/nose[${PYTHON_USEDEP}] )
35         dev-python/setuptools[${PYTHON_USEDEP}]"
36
37 python_test() {
38         nosetests || die
39 }