*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-crypt / acme / acme-0.40.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=(python{2_7,3_6,3_7})
6
7 if [[ ${PV} == 9999* ]]; then
8         EGIT_REPO_URI="https://github.com/certbot/certbot.git"
9         inherit git-r3
10         S=${WORKDIR}/${P}/${PN}
11 else
12         SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
13         KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
14         S=${WORKDIR}/certbot-${PV}/acme
15 fi
16
17 inherit distutils-r1
18
19 DESCRIPTION="An implementation of the ACME protocol"
20 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
21
22 LICENSE="Apache-2.0"
23 SLOT="0"
24 IUSE="doc test"
25 RESTRICT="!test? ( test )"
26
27 RDEPEND="
28         >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
29         >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
30         >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
31         dev-python/mock[${PYTHON_USEDEP}]
32         >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
33         dev-python/pyrfc3339[${PYTHON_USEDEP}]
34         dev-python/pytz[${PYTHON_USEDEP}]
35         >=dev-python/requests-2.10[${PYTHON_USEDEP}]
36         >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
37         >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
38 "
39 DEPEND="
40         doc? (
41                 dev-python/sphinx[${PYTHON_USEDEP}]
42                 dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
43         )
44         test? (
45                 ${RDEPEND}
46                 dev-python/nose[${PYTHON_USEDEP}]
47                 dev-python/pytest[${PYTHON_USEDEP}]
48                 dev-python/pytest-xdist[${PYTHON_USEDEP}]
49         )
50         >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
51 "
52
53 src_compile() {
54         python_foreach_impl run_in_build_dir default
55         if use doc ; then
56                 cd docs || die
57                 sphinx-build -b html -d _build/doctrees   . _build/html
58         fi
59 }
60
61 python_test() {
62         nosetests -w ${PN} || die
63 }
64
65 python_install_all() {
66         use doc && local HTML_DOCS=( docs/_build/html/. )
67
68         distutils-r1_python_install_all
69 }