1d65de24f5e18f69c594c19d33e2c90f9a114e16
[gentoo.git] / app-arch / ncompress / ncompress-4.2.4.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Classic compress & uncompress programs for .Z (LZW) files"
9 HOMEPAGE="https://github.com/vapier/ncompress"
10 SRC_URI="https://github.com/vapier/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="public-domain"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
15 IUSE=""
16
17 src_compile() {
18         tc-export CC
19         emake
20 }
21
22 src_install() {
23         dobin compress
24         dosym compress /usr/bin/uncompress
25         doman compress.1 uncompress.1
26         dodoc Acknowleds Changes LZW.INFO README.md
27 }