ebd9c24d38fdbd5dfae9a29fbf06de308260206b
[gentoo.git] / app-arch / lbzip2 / lbzip2-2.5_p20181227-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 inherit autotools
7
8 DESCRIPTION="Parallel bzip2 utility"
9 HOMEPAGE="https://github.com/kjn/lbzip2/"
10 SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
15 IUSE="debug symlink"
16
17 RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
18 DEPEND=""
19
20 PATCHES=(
21         "${FILESDIR}"/${PN}-2.3-s_isreg.patch
22         "${FILESDIR}"/${P}-fix-unaligned.patch
23 )
24
25 src_prepare() {
26         default
27         eautoreconf
28 }
29
30 src_configure() {
31         local myeconfargs=(
32                 $(use_enable debug tracing)
33         )
34         econf "${myeconfargs[@]}"
35 }
36
37 src_install() {
38         default
39
40         if use symlink; then
41                 dosym ${PN} /usr/bin/bzip2
42                 dosym lbunzip2 /usr/bin/bunzip2
43         fi
44 }