*/*: Discontinue Gentoo SuperH port
[gentoo.git] / app-arch / gzip / gzip-1.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit flag-o-matic
7
8 DESCRIPTION="Standard GNU compressor"
9 HOMEPAGE="https://www.gnu.org/software/gzip/"
10 SRC_URI="mirror://gnu/gzip/${P}.tar.xz
11         mirror://gnu-alpha/gzip/${P}.tar.xz
12         mirror://gentoo/${P}.tar.xz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17 IUSE="pic static"
18
19 PATCHES=(
20         "${FILESDIR}/${PN}-1.3.8-install-symlinks.patch"
21 )
22
23 src_configure() {
24         use static && append-flags -static
25         # avoid text relocation in gzip
26         use pic && export DEFS="NO_ASM"
27         econf --disable-gcc-warnings #663928
28 }
29
30 src_install() {
31         default
32         docinto txt
33         dodoc algorithm.doc gzip.doc
34
35         # keep most things in /usr, just the fun stuff in /
36         dodir /bin
37         mv "${ED%/}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${ED%/}"/bin/ || die
38         sed -e "s:${EPREFIX}/usr:${EPREFIX}:" -i "${ED%/}"/bin/gunzip || die
39 }