*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / app-admin / stow / stow-2.3.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit perl-functions
7
8 DESCRIPTION="GNU Stow is a symlink farm manager"
9 HOMEPAGE="https://www.gnu.org/software/stow/"
10 SRC_URI="mirror://gnu/stow/${P}.tar.gz"
11
12 LICENSE="GPL-3+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="dev-lang/perl
19         test? (
20                 dev-perl/IO-stringy
21                 virtual/perl-Test-Harness
22                 dev-perl/Test-Output
23         )"
24 RDEPEND="dev-lang/perl:="
25
26 src_configure() {
27         perl_set_version
28         econf "--with-pmdir=${VENDOR_LIB}"
29 }