*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-admin / gixy / gixy-0.1.20.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Nginx configuration static analyzer"
11 HOMEPAGE="https://github.com/yandex/gixy"
12 # Use GitHub source insted PyPi to get tarball with tests
13 SRC_URI="https://github.com/yandex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="MPL-2.0"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND=">=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
22         >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
23         >=dev-python/configargparse-0.11.0[${PYTHON_USEDEP}]
24         >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
25         >=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
26
27 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
28         test? (
29                 dev-python/nose[${PYTHON_USEDEP}]
30                 ${RDEPEND}
31         )
32 "
33
34 python_prepare() {
35         sed -i -e "/argparse/d" setup.py || die
36         distutils-r1_python_prepare_all
37 }
38
39 python_test() {
40         nosetests -v || die
41 }