*/*: Discontinue Gentoo SuperH port
[gentoo.git] / app-accessibility / at-spi2-atk / at-spi2-atk-2.34.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit gnome.org meson multilib-minimal virtualx xdg
7
8 DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
9 HOMEPAGE="https://wiki.gnome.org/Accessibility"
10
11 LICENSE="LGPL-2.1+"
12 SLOT="2"
13 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
19         >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
20         >=dev-libs/atk-2.33.3[${MULTILIB_USEDEP}]
21         >=app-accessibility/at-spi2-core-2.33.2[${MULTILIB_USEDEP}]
22 "
23 DEPEND="${RDEPEND}"
24 BDEPEND="
25         virtual/pkgconfig[${MULTILIB_USEDEP}]
26         test? ( >=dev-libs/libxml2-2.9.1 )
27 "
28
29 multilib_src_configure() {
30         meson_src_configure
31 }
32
33 multilib_src_compile() {
34         meson_src_compile
35 }
36
37 multilib_src_test() {
38         virtx dbus-run-session meson test -C "${BUILD_DIR}"
39 }
40
41 multilib_src_install() {
42         meson_src_install
43 }