Fix a relative path bug
[catalyst.git] / examples / tinderbox_template.spec
1 # generic tinderbox specfile
2
3 # The subarch can be any of the supported catalyst subarches (like athlon-xp).
4 # Refer to "man catalyst" or <http://www.gentoo.org/proj/en/releng/catalyst/>
5 # for supported subarches
6 # example:
7 # subarch: athlon-xp
8 subarch:
9
10 # The version stamp is an identifier for the build.  It can be anything you wish# it to be, but it is usually a date.
11 # example:
12 # version_stamp: 2006.1
13 version_stamp:
14
15 # The target specifies what target we want catalyst to do.
16 # example:
17 # target: tinderbox
18 target: tinderbox
19
20 # The rel_type defines what kind of build we are doing.  This is merely another
21 # identifier, but it useful for allowing multiple concurrent builds.  Usually,
22 # default will suffice.
23 # example:
24 # rel_type: default
25 rel_type:
26
27 # This is the system profile to be used by catalyst to build this target.  It is# specified as a relative path from /usr/portage/profiles.
28 # example:
29 # profile: default-linux/x86/2006.1
30 profile:
31
32 # This specifies which snapshot to use for building this target.
33 # example:
34 # snapshot: 2006.1
35 snapshot:
36
37 # This specifies where the seed stage comes from for this target,  The path is
38 # relative to $clst_sharedir/builds.  The rel_type is also used as a path prefix# for the seed.
39 # example:
40 # default/stage3-x86-2006.1
41 source_subpath:
42
43 # These are the hosts used as distcc slaves when distcc is enabled in your
44 # catalyst.conf.  It follows the same syntax as distcc-config --set-hosts and
45 # is entirely optional.
46 # example:
47 # distcc_hosts: 127.0.0.1 192.168.0.1
48 distcc_hosts:
49
50 # This is an optional directory containing portage configuration files.  It
51 # follows the same syntax as /etc/portage and should be consistent across all
52 # targets to minimize problems.
53 # example:
54 # portage_confdir: /etc/portage
55 portage_confdir:
56
57 # This option specifies the location to a portage overlay that you would like to
58 # have used when building this target.
59 # example:
60 # portage_overlay: /usr/local/portage
61 portage_overlay:
62
63 # This allows the optional directory containing the output packages for
64 # catalyst.  Mainly used as a way for different spec files to access the same
65 # cache directory.  Default behavior is for this location to be autogenerated
66 # by catalyst based on the spec file.
67 # example:
68 # pkgcache_path: /tmp/packages
69 pkgcache_path:
70
71 # The tinderbox target can build packages with any USE settings.  However, it
72 # should be noted that these settings are additive to the settings in the
73 # chosen profile.  This is extremely useful when testing possible changed to a
74 # profile or package.
75 # example:
76 # tinderbox/use: gtk2 gnome kde qt bonobo cdr esd gtkhtml mozilla mysql perl ruby tcltk cups ldap ssl tcpd -svga
77 tinderbox/use:
78
79 # This is the list of packages that will be built by the tinderbox target.
80 # Each of these is considered a separate target to test, and catalyst will use
81 # rsync to reset the build area to the default from the source_subpath before
82 # each package.  This allows for testing USE changes on individual packages as
83 # well as for dependency issues.
84 # exampleL
85 # tinderbox/packages: dante tsocks sys-apps/eject minicom links acpid apmd parted whois tcpdump cvs zip unzip netcat partimage app-admin/sudo app-cdr/cdrtools gnome emacs dev-lang/ruby enlightenment kde mozilla-firefox mozilla-thunderbird xfce4 openbox fluxbox sylpheed openoffice-bin gimp xemacs xmms abiword gaim xchat pan tetex xcdroast k3b samba nmap gradm ettercap ethereal mplayer
86 tinderbox/packages:
87
88 # Setting the option overrides the location of the kerncache
89 kerncache_path:
90