Fix a relative path bug
[catalyst.git] / examples / stage4_template.spec
1 # stage4 example specfile
2 # used to build a stage4
3
4 # The subarch can be any of the supported catalyst subarches (like athlon-xp).
5 # Refer to "man catalyst" or <http://www.gentoo.org/proj/en/releng/catalyst/>
6 # for supported subarches
7 # example:
8 # subarch: athlon-xp
9 subarch:
10
11 # The version stamp is an identifier for the build.  It can be anything you wish# it to be, but it is usually a date.
12 # example:
13 # version_stamp: 2006.1
14 version_stamp:
15
16 # The target specifies what target we want catalyst to do.  For building a CD,
17 # we start with stage4 as our target.
18 # example:
19 # target: stage4
20 target:
21
22 # The rel_type defines what kind of build we are doing.  This is merely another
23 # identifier, but it useful for allowing multiple concurrent builds.  Usually,
24 # default will suffice.
25 # example:
26 # rel_type: default
27 rel_type:
28
29 # This is the system profile to be used by catalyst to build this target.  It is# specified as a relative path from /usr/portage/profiles.
30 # example:
31 # profile: default-linux/x86/2006.1
32 profile:
33
34 # This specifies which snapshot to use for building this target.
35 # example:
36 # snapshot: 2006.1
37 snapshot:
38
39 # This specifies where the seed stage comes from for this target,  The path is
40 # relative to $clst_sharedir/builds.  The rel_type is also used as a path prefix# for the seed.
41 # example:
42 # default/stage3-x86-2006.1
43 source_subpath:
44
45 # These are the hosts used as distcc slaves when distcc is enabled in your
46 # catalyst.conf.  It follows the same syntax as distcc-config --set-hosts and
47 # is entirely optional.
48 # example:
49 # distcc_hosts: 127.0.0.1 192.168.0.1
50 distcc_hosts:
51
52 # This is an optional directory containing portage configuration files.  It
53 # follows the same syntax as /etc/portage and should be consistent across all
54 # targets to minimize problems.
55 # example:
56 # portage_confdir: /etc/portage
57 portage_confdir:
58
59 # This option specifies the location to a portage overlay that you would like to
60 # have used when building this target.
61 # example:
62 # portage_overlay: /usr/local/portage
63 portage_overlay:
64
65 # This allows the optional directory containing the output packages for
66 # catalyst.  Mainly used as a way for different spec files to access the same
67 # cache directory.  Default behavior is for this location to be autogenerated
68 # by catalyst based on the spec file.
69 # example:
70 # pkgcache_path: /tmp/packages
71 pkgcache_path:
72
73 # This allows the optional directory containing the output packages for kernel
74 # builds.  Mainly used as a way for different spec files to access the same
75 # cache directory.  Default behavior is for this location to be autogenerated
76 # by catalyst based on the spec file.
77 # example:
78 # kerncache_path: /tmp/kernel
79 kerncache_path:
80
81 # The stage4 target is where you will build packages for basically updated
82 # stage3.  These packages can be built with customized USE settings.  The
83 # settings here are additive to the default USE configured by the profile.
84 # Leaving this blank will default to the system use flags
85 # example:
86 # stage4/use: ipv6 socks5 fbcon ncurses readline ssl
87 stage4/use:
88
89 # This is the set of packages that we will merge into the stage4 tarball.  They
90 # will be built with the USE flags configured above.  These packages must not
91 # depend on a configured kernel.  If the package requires a configured kernel,
92 # then it will be defined elsewhere.
93 # example:
94 # stage4/packages: livecd-tools dhcpcd acpid apmd gentoo-sources coldplug fxload irssi gpm syslog-ng parted links raidtools dosfstools nfs-utils jfsutils xfsprogs e2fsprogs reiserfsprogs ntfsprogs pwgen rp-pppoe screen mirrorselect penggy iputils hwdata-knoppix hwsetup lvm2 evms vim pptpclient mdadm ethtool wireless-tools prism54-firmware wpa_supplicant
95 stage4/packages:
96
97 # A fsscript is simply a shell script that is copied into the chroot of the stage4
98 # after the kernel(s) and any external modules have been compiled and is
99 # executed within the chroot.  It can contain any commands that are available
100 # via the packages installed by our stages or by the packages installed during
101 # the stage4-stage1 build.  We do not use one for the official release media, so
102 # there will not be one listed below.  The syntax is simply the full path and
103 # filename to the shell script that you wish to execute.  The script is copied
104 # into the chroot by catalyst automatically.
105 # example:
106 # stage4/fsscript:
107 stage4/fsscript:
108
109 # This is where you set the splash theme.  This theme must be present in
110 # /etc/splash, before the kernel has completed building.
111 # example:
112 # stage4/splash_theme: livecd-2006.1
113 stage4/splash_theme:
114
115 # This is a set of arguments that will be passed to genkernel for all kernels
116 # defined in this target.  It is useful for passing arguments to genkernel that
117 # are not otherwise available via the stage4-stage2 spec file.
118 # example:
119 # stage4/gk_mainargs: --lvm --dmraid
120 stage4/gk_mainargs:
121
122 # This option allows you to specify your own linuxrc script for genkernel to use# when building your CD.  This is not checked for functionality, so it is up to
123 # you to debug your own script.  We do not use one for the official release
124 # media, so there will not be one listed below.
125 # example:
126 # stage4/linuxrc:
127 stage4/linuxrc:
128
129 # This is for the message of the day.  It is not required
130 # release media, as catalyst builds a default motd when the stage4/type is set
131 # to one of the gentoo-* options.  This setting overrides the default motd even
132 # on official media.  Since we do not use this for the official releases, it is
133 # left blank below.
134 # example:
135 # stage4/motd:
136 stage4/motd:
137
138 # This is for blacklisting modules from being hotplugged that are known to cause
139 # problems.  Putting a module name here will keep it from being auto-loaded,
140 # even if ti is detected by hotplug.
141 # example:
142 # stage4/modblacklist: 8139cp
143 stage4/modblacklist:
144
145 # This is for adding init scripts to runlevels.  The syntax for the init script
146 # is the script name, followed by a pipe, followed by the runlevel in which you
147 # want the script to run.  It looks like spind|default and is space delimited.
148 # We do not use this on the official media, as catalyst sets up the runlevels
149 # correctly for us.  Since we do not use this, it is left blank below.
150 # example:
151 # stage4/rcadd:
152 stage4/rcadd:
153
154 # This is for removing init script from runlevels.  It is executed after the
155 # defaults shipped with catalyst, so it is possible to remove the defaults using
156 # this option.  It can follow the same syntax as livcd/rcadd, or you can leave
157 # the runlevel off to remove the script from any runlevels detected.  We do not
158 # use this on the official media, so it is left blank.
159 # example:
160 # stage4/rcdel:
161 stage4/rcdel:
162
163 # This overlay is dropped onto the filesystem within the loop.  This can be used
164 # for such things as updating configuration files or adding anything else you
165 # would want within your stage4 filesystem.  Files added here are available when
166 # docache is used.  We do not use this on the official media, so we will leave
167 # it blank below.
168 # example:
169 # stage4/root_overlay:
170 stage4/root_overlay:
171
172 # This is used by catalyst to copy the specified file to /etc/X11/xinit/xinitrc
173 # and is used by the stage4/type gentoo-gamecd and generic-livecd.  While the
174 # file will still be copied for any stage4/type, catalyst will only create the
175 # necessary /etc/startx for those types, so X will not be automatically started.
176 # This is useful also for setting up X on a CD where you do not wish X to start
177 # automatically.  We do not use this on the release media, so it is left blank.
178 # example:
179 # stage4/xinitrc:
180 stage4/xinitrc:
181
182 # This option is used to create non-root users on your CD.  It takes a space
183 # separated list of user names.  These users will be added to the following
184 # groups: users,wheel,audio,games,cdrom,usb
185 # If this is specified in your spec file, then the first user is also the user
186 # used to start X. Since this is not used on the release media, it is blank.
187 # example:
188 # stage4/users:
189 stage4/users:
190
191 # This option is used to specify the number of kernels to build and also the
192 # labels that will be used by the CD bootloader to refer to each kernel image.
193 # example:
194 # boot/kernel: gentoo
195 boot/kernel:
196
197 # This option tells catalyst which kernel sources to merge for this kernel
198 # label.  This can use normal portage atoms to specify a specific version.
199 # example:
200 # boot/kernel/gentoo/sources: gentoo-sources
201 boot/kernel/gentoo/sources:
202
203 # This option is the full path and filename to a kernel .config file that is
204 # used by genkernel to compile the kernel this label applies to.
205 # example:
206 # boot/kernel/gentoo/config: /tmp/2.6.11-smp.config
207 boot/kernel/gentoo/config:
208
209 # This option sets genkernel parameters on a per-kernel basis and applies only
210 # to this kernel label.  This can be used for building options into only a
211 # single kernel, where compatibility may be an issue.  Since we do not use this
212 # on the official release media, it is left blank, but it follows the same
213 # syntax as stage4/gk_mainargs.
214 # example:
215 # boot/kernel/gentoo/gk_kernargs:
216 boot/kernel/gentoo/gk_kernargs:
217
218 # This option sets the USE flags used to build the kernel and also any packages
219 # which are defined under this kernel label.  These USE flags are additive from
220 # the default USE for the specified profile.
221 # example:
222 # boot/kernel/gentoo/use: pcmcia usb -X
223 boot/kernel/gentoo/use:
224
225 # This option appends an extension to the name of your kernel, as viewed by a
226 # uname -r/  This also affects any modules built under this kernel label.  This
227 # is useful for having two kernels using the same sources to keep the modules
228 # from overwriting each other.  We do not use this on the official media, so it
229 # is left blank.
230 # example:
231 # boot/kernel/gentoo/extraversion:
232 boot/kernel/gentoo/extraversion:
233
234 # This option is for merging kernel-dependent packages and external modules that
235 # are configured against this kernel label.
236 # example:
237 # boot/kernel/gentoo/packages: pcmcia-cs speedtouch slmodem globespan-adsl hostap-driver hostap-utils ipw2100 ipw2200 fritzcapi fcdsl cryptsetup
238 boot/kernel/gentoo/packages:
239
240 # This is a list of packages that will be unmerged after all the kernels have
241 # been built.  There are no checks on these packages, so be careful what you
242 # add here.  They can potentially break your CD.
243 # example:
244 # stage4/unmerge: acl attr autoconf automake bin86 binutils libtool m4 bison ld.so make perl patch linux-headers man-pages sash bison flex gettext texinfo ccache distcc man groff lib-compat miscfiles rsync sysklogd bc lcms libmng genkernel diffutils libperl gnuconfig gcc-config gcc bin86 cpio cronbase ed expat grub lilo help2man libtool gentoo-sources
245 stage4/unmerge:
246
247 # This option is used to empty the directories listed.  It is useful for getting
248 # rid of files that don't belong to a particular package, or removing files from
249 # a package that you wish to keep, but won't need the full functionality.
250 # example:
251 # stage4/empty: /var/tmp /var/cache /var/db /var/empty /var/lock /var/log /var/run /var/spool /var/state /tmp /usr/portage /usr/share/man /usr/share/info /usr/share/unimaps /usr/include /usr/share/zoneinfo /usr/share/dict /usr/share/doc /usr/share/ss /usr/share/state /usr/share/texinfo /usr/lib/python2.2 /usr/lib/portage /usr/share/gettext /usr/share/i18n /usr/share/rfc /usr/lib/X11/config /usr/lib/X11/etc /usr/lib/X11/doc /usr/src /usr/share/doc /usr/share/man /root/.ccache /etc/cron.daily /etc/cron.hourly /etc/cron.monthly /etc/cron.weekly /etc/logrotate.d /etc/rsync /usr/lib/awk /usr/lib/ccache /usr/lib/gcc-config /usr/lib/nfs /usr/local /usr/diet/include /usr/diet/man /usr/share/consolefonts/partialfonts /usr/share/consoletrans /usr/share/emacs /usr/share/gcc-data /usr/share/genkernel /etc/splash/gentoo /etc/splash/emergence /usr/share/gnuconfig /usr/share/lcms /usr/share/locale /etc/skel
252 stage4/empty:
253
254 # This option tells catalyst to clean specific files from the filesystem and is
255 # very usefu in cleaning up stray files in /etc left over after stage4/unmerge.
256 # example:
257 # stage4/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/portage/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2006.1/16* /etc/splash/livecd-2006.1/12* /etc/splash/livecd-2006.1/6* /etc/splash/livecd-2006.1/8* /etc/splash/livecd-2006.1/images/silent-16* /etc/splash/livecd-2006.1/images/silent-12* /etc/splash/livecd-2006.1/images/silent-6* /etc/splash/livecd-2006.1/images/silent-8* /etc/splash/livecd-2006.1/images/verbose-16* /etc/splash/livecd-2006.1/images/verbose-12* /etc/splash/livecd-2006.1/images/verbose-6* /etc/splash/livecd-2006.1/images/verbose-8* /etc/portage/make.conf.example /etc/make.globals /etc/resolv.conf
258 stage4/rm: