modules/generic_stage_target.py: Use 'devpts' as mountmap key.
[catalyst.git] / examples / netboot_template.spec
1 # generic netboot image specfile
2 # used to build a network bootable image
3
4 # The subarch can be any of the supported catalyst subarches (like athlon-xp).
5 # Refer to "man catalyst" or <http://www.gentoo.org/proj/en/releng/catalyst/>
6 # for supported subarches
7 # example:
8 # subarch: athlon-xp
9 subarch:
10
11 # The version stamp is an identifier for the build.  It can be anything you wish# it to be, but it is usually a date.
12 # example:
13 # version_stamp: 2006.1
14 version_stamp:
15
16 # The target specifies what target we want catalyst to do.  For building a
17 # netboot image, we use the netboot target.
18 # example:
19 # target: netboot
20 target:
21
22 # The rel_type defines what kind of build we are doing.  This is merely another
23 # identifier, but it useful for allowing multiple concurrent builds.  Usually,
24 # default will suffice.
25 # example:
26 # rel_type: default
27 rel_type:
28
29 # This is the system profile to be used by catalyst to build this target.  It is# specified as a relative path from /usr/portage/profiles.
30 # example:
31 # profile: default-linux/x86/2006.1
32 profile:
33
34 # This specifies which snapshot to use for building this target.
35 # example:
36 # snapshot: 2006.1
37 snapshot:
38
39 # This specifies where the seed stage comes from for this target,  The path is
40 # relative to $clst_sharedir/builds.  The rel_type is also used as a path prefix# for the seed.
41 # example:
42 # default/stage3-x86-2006.1
43 source_subpath:
44
45 # These are the hosts used as distcc slaves when distcc is enabled in your
46 # catalyst.conf.  It follows the same syntax as distcc-config --set-hosts and
47 # is entirely optional.
48 # example:
49 # distcc_hosts: 127.0.0.1 192.168.0.1
50 distcc_hosts:
51
52 # This is an optional directory containing portage configuration files.  It
53 # follows the same syntax as /etc/portage and should be consistent across all
54 # targets to minimize problems.
55 # example:
56 # portage_confdir: /etc/portage
57 portage_confdir:
58
59 # This option specifies the location to a portage overlay that you would like to
60 # have used when building this target.
61 # example:
62 # portage_overlay: /usr/local/portage
63 portage_overlay:
64
65 # This allows the optional directory containing the output packages for
66 # catalyst.  Mainly used as a way for different spec files to access the same
67 # cache directory.  Default behavior is for this location to be autogenerated
68 # by catalyst based on the spec file.
69 # example:
70 # pkgcache_path: /tmp/packages
71 pkgcache_path:
72
73 # This allows the optional directory containing the output packages for kernel
74 # builds.  Mainly used as a way for different spec files to access the same
75 # cache directory.  Default behavior is for this location to be autogenerated
76 # by catalyst based on the spec file.
77 # example:
78 # kerncache_path: /tmp/kernel
79 kerncache_path:
80
81 # This option tells catalyst which kernel sources to merge for building this
82 # image.  This can use normal portage atoms to specify a specific version.
83 # example:
84 # netboot/kernel/sources: gentoo-sources
85 netboot/kernel/sources:
86
87 # This option is the full path and filename to a kernel .config file that is
88 # used by genkernel to compile the kernel for this image.
89 # example:
90 # netboot/kernel/config: /tmp/2.6.11-netboot.config
91 netboot/kernel/config:
92
93 # This option sets the USE flags used to build the kernel.  These USE flags are
94 # additive from the default USE for the specified profile.
95 # example:
96 # netboot/kernel/use: ultra1
97 netboot/kernel/use:
98
99 # This option sets the USE flags with which the optional packages below are
100 # built.  Like the kernel USE, they are additive.
101 # example:
102 # netboot/use:
103 netboot/use:
104
105 # The netboot target builds busybox for its root filesystem.  This option is
106 # where you specify the full path and filename to your busybox configuration.
107 # example
108 # netboot/busybox_config: /tmp/busybox.config
109 netboot/busybox_config:
110
111 # This is the full path and filename to the tarball to use as the base for the
112 # netboot image.
113 # example:
114 # netboot/base_tarball: /usr/lib/catalyst/netboot/netboot-base.tar.bz2
115 netboot/base_tarball:
116
117 # These are the packages that will be built for your netboot image using the USE
118 # flags set in netboot/use.  These package names are also labels used later when
119 # determining what files to copy into your netboot image.
120 # example:
121 # netboot/packages: raidtools xfsprogs e2fsprogs reiserfsprogs
122
123 # This is where you tell catalyst which files from each package to copy into the
124 # netboot image.
125 # example:
126 # netboot/packages/raidtools/files: /sbin/raidstart /sbin/mkraid /sbin/detect_multipath /sbin/raidreconf /sbin/raidstop /sbin/raidhotadd /sbin/raidhotremove /sbin/raidsetfaulty /sbin/raid0run
127 netboot/packages/raidtools/files:
128
129 # Here is the same thing for xfsprogs.
130 # example:
131 # netboot/packages/xfsprogs/files: /sbin/mkfs.xfs /sbin/xfs_repair /bin/xfs_check
132 netboot/packages/xfsprogs/files:
133
134 # Here is the same thing for e2fsprogs.
135 # example:
136 # netboot/packages/e2fsprogs/files: /sbin/mke2fs
137 netboot/packages/e2fsprogs/files:
138
139 # Here is the same thing for reiserfsprogs.
140 # example:
141 # netboot/packages/reiserfsprogs/files: /sbin/mkreiserfs
142 netboot/packages/reiserfsprogs/files:
143
144 # This is a list of any other files, not belonging to the above packages, that
145 # you would wish to have copied into your netboot image.
146 # example:
147 # netboot/extra_files: /lib/libresolv.so.2 /lib/libnss_compat.so.2 /lib/libnss_dns.so.2 /lib/libnss_files.so.2 /sbin/consoletype
148 netboot/extra_files:
149