Drop addpatches from the livecd-stage2 example spec as well.
[catalyst.git] / examples / livecd-stage2_template.spec
1 # livecd-stage2 example specfile
2 # used to build a livecd-stage2 iso image
3
4 # The subarch can be any of the supported catalyst subarches (like athlon-xp).
5 # Refer to "man catalyst" or <http://www.gentoo.org/proj/en/releng/catalyst/>
6 # for supported subarches
7 # example:
8 # subarch: athlon-xp
9 subarch:
10
11 # The version stamp is an identifier for the build.  It can be anything you wish# it to be, but it is usually a date.
12 # example:
13 # version_stamp: 2006.1
14 version_stamp:
15
16 # The target specifies what target we want catalyst to do.  For building a CD,
17 # we continue with livecd-stage2 as the target.
18 # example:
19 # target: livecd-stage2
20 target:
21
22 # The rel_type defines what kind of build we are doing.  This is merely another
23 # identifier, but it useful for allowing multiple concurrent builds.  Usually,
24 # default will suffice.
25 # example:
26 # rel_type: default
27 rel_type:
28
29 # This is the system profile to be used by catalyst to build this target.  It is# specified as a relative path from /usr/portage/profiles.
30 # example:
31 # profile: default-linux/x86/2006.1
32 profile:
33
34 # This specifies which snapshot to use for building this target.
35 # example:
36 # snapshot: 2006.1
37 snapshot:
38
39 # This specifies where the seed stage comes from for this target,  The path is
40 # relative to $clst_sharedir/builds.  The rel_type is also used as a path prefix# for the seed.
41 # example:
42 # default/livecd-stage1-x86-2006.1
43 source_subpath:
44
45 # These are the hosts used as distcc slaves when distcc is enabled in your
46 # catalyst.conf.  It follows the same syntax as distcc-config --set-hosts and
47 # is entirely optional.
48 # example:
49 # distcc_hosts: 127.0.0.1 192.168.0.1
50 distcc_hosts:
51
52 # This is an optional directory containing portage configuration files.  It
53 # follows the same syntax as /etc/portage and should be consistent across all
54 # targets to minimize problems.
55 # example:
56 # portage_confdir: /etc/portage
57 portage_confdir:
58
59 # This option specifies the location to a portage overlay that you would like to
60 # have used when building this target.
61 # example:
62 # portage_overlay: /usr/local/portage
63 portage_overlay:
64
65 # This allows the optional directory containing the output packages for
66 # catalyst.  Mainly used as a way for different spec files to access the same
67 # cache directory.  Default behavior is for this location to be autogenerated
68 # by catalyst based on the spec file.
69 # example:
70 # pkgcache_path: /tmp/packages
71 pkgcache_path:
72
73 # This allows the optional directory containing the output packages for kernel
74 # builds.  Mainly used as a way for different spec files to access the same
75 # cache directory.  Default behavior is for this location to be autogenerated
76 # by catalyst based on the spec file.
77 # example:
78 # kerncache_path: /tmp/kernel
79 kerncache_path:
80
81 # The fstype is used to determine what sort of CD we should build.  This is
82 # used to set the type of loopback filesystem that we will use on our CD.
83 # Possible options are as follows:
84 # squashfs - This gives the best compression, but requires a kernel patch.
85 # zisofs - This uses in-kernel compression and is supported on all platforms.
86 # normal - This creates a loop without compression.
87 # noloop - This copies the files to the CD directly, without using a loopback.
88 # example:
89 # livecd/fstype: squashfs
90 livecd/fstype:
91
92 # The fsops are a list of optional parameters that can be passed to the tool
93 # which will create the filesystem specified in livecd/fstype.  It is valid for
94 # the following fstypes: squashfs, jffs, jffs2, cramfs
95 # example:
96 # livecd/fsops: -root-owned
97 livecd/fsops:
98
99 # The cdtar is essentially the bootloader for the CD.  It also holds the main
100 # configuration for the bootloader.  On x86/amd64, it also can include a small
101 # memory testing application, called memtest86+.
102 # example:
103 # livecd/cdtar: /usr/lib/catalyst/livecd/cdtar/isolinux-2.13-memtest86+-cdtar.tar.bz2
104 livecd/cdtar:
105
106 # This is the full path and filename to the ISO image that the livecd-stage2
107 # target will create.
108 # example:
109 # livecd/iso: /tmp/installcd-x86-minimal.iso
110 livecd/iso:
111
112 # A fsscript is simply a shell script that is copied into the chroot of the CD
113 # after the kernel(s) and any external modules have been compiled and is
114 # executed within the chroot.  It can contain any commands that are available
115 # via the packages installed by our stages or by the packages installed during
116 # the livecd-stage1 build.  We do not use one for the official release media, so
117 # there will not be one listed below.  The syntax is simply the full path and
118 # filename to the shell script that you wish to execute.  The script is copied
119 # into the chroot by catalyst automatically.
120 # example:
121 # livecd/fsscript:
122 livecd/fsscript:
123
124 # This is where you set the splash theme.  This theme must be present in
125 # /etc/splash, before the kernel has completed building.
126 # example:
127 # livecd/splash_theme: livecd-2006.1
128 livecd/splash_theme:
129
130 # This is a set of arguments that get passed to the bootloader for your CD.  It
131 # is used on the x86/amd64 release media to enable keymap selection.
132 # example:
133 # livecd/bootargs: dokeymap
134 livecd/bootargs:
135
136 # This is a set of arguments that will be passed to genkernel for all kernels
137 # defined in this target.  It is useful for passing arguments to genkernel that
138 # are not otherwise available via the livecd-stage2 spec file.
139 # example:
140 # livecd/gk_mainargs: --lvm --dmraid
141 livecd/gk_mainargs:
142
143 # This option allows you to specify your own linuxrc script for genkernel to use
144 # when building your CD.  This is not checked for functionality, so it is up to
145 # you to debug your own script.  We do not use one for the official release
146 # media, so there will not be one listed below.
147 # example:
148 # livecd/linuxrc:
149 livecd/linuxrc:
150
151 # This option controls quite a bit of catalyst internals and sets up several
152 # defaults.  Each type behaves slightly differently and is explained below.
153 # gentoo-release-minimal - This creates an official minimal InstallCD.
154 # gentoo-release-universal - This creates an official universal InstallCD.
155 # gentoo-release-livecd - This creates an official LiveCD environment.
156 # gentoo-gamecd - This creates an official Gentoo GameCD.
157 # generic-livecd - This should be used for all non-official media.
158 # example:
159 # livecd/type: gentoo-release-minimal
160 livecd/type:
161
162 # This is for the README.txt on the root of the CD.  For Gentoo releases, we
163 # use a default README.txt, and this will be used on your CD if you do not
164 # provide one yourself.  Since we do not use this for the official releases, it
165 # is left blank below.
166 # example:
167 # livecd/readme:
168 livecd/readme:
169
170 # This is for the CD's message of the day.  It is not required for official
171 # release media, as catalyst builds a default motd when the livecd/type is set
172 # to one of the gentoo-* options.  This setting overrides the default motd even
173 # on official media.  Since we do not use this for the official releases, it is
174 # left blank below.
175 # example:
176 # livecd/motd:
177 livecd/motd:
178
179 # This is for blacklisting modules from being hotplugged that are known to cause
180 # problems.  Putting a module name here will keep it from being auto-loaded,
181 # even if ti is detected by hotplug.
182 # example:
183 # livecd/modblacklist: 8139cp
184 livecd/modblacklist:
185
186 # This is for adding init scripts to runlevels.  The syntax for the init script
187 # is the script name, followed by a pipe, followed by the runlevel in which you
188 # want the script to run.  It looks like spind|default and is space delimited.
189 # We do not use this on the official media, as catalyst sets up the runlevels
190 # correctly for us.  Since we do not use this, it is left blank below.
191 # This option will automatically create missing runlevels
192 # example:
193 # livecd/rcadd:
194 livecd/rcadd:
195
196 # This is for removing init script from runlevels.  It is executed after the
197 # defaults shipped with catalyst, so it is possible to remove the defaults using
198 # this option.  It can follow the same syntax as livcd/rcadd, or you can leave
199 # the runlevel off to remove the script from any runlevels detected.  We do not
200 # use this on the official media, so it is left blank.
201 # example:
202 # livecd/rcdel:
203 livecd/rcdel:
204
205 # This overlay is dropped onto the CD filesystem and is outside any loop which
206 # has been configured.  This is typically used for adding the documentation,
207 # distfiles, snapshots, and stages to the official media.  These files will not
208 # be available if docache is enabled, as they are outside the loop.
209 # example:
210 # livecd/overlay: /tmp/overlay-minimal
211 livecd/overlay:
212
213 # This overlay is dropped onto the filesystem within the loop.  This can be used
214 # for such things as updating configuration files or adding anything else you
215 # would want within your CD filesystem.  Files added here are available when
216 # docache is used.  We do not use this on the official media, so we will leave
217 # it blank below.
218 # example:
219 # livecd/root_overlay:
220 livecd/root_overlay:
221
222 # This is used by catalyst to copy the specified file to /etc/X11/xinit/xinitrc
223 # and is used by the livecd/type gentoo-gamecd and generic-livecd.  While the
224 # file will still be copied for any livecd/type, catalyst will only create the
225 # necessary /etc/startx for those types, so X will not be automatically started.
226 # This is useful also for setting up X on a CD where you do not wish X to start
227 # automatically.  We do not use this on the release media, so it is left blank.
228 # example:
229 # livecd/xinitrc:
230 livecd/xinitrc:
231
232 # This is used by catalyst to determine which display manager you wish to
233 # become the default.  This is used on the official Gentoo LiveCD and is valid
234 # for any livecd/type.
235 # example:
236 # livecd/xdm: gdm
237 livecd/xdm:
238
239 # This is used by catalyst to determine which X session should be started by
240 # default by the display manager.  This is used on the official Gentoo LiveCD
241 # and is valid for any livecd/type.
242 # example:
243 # livecd/xsession: gnome
244 livecd/xsession:
245
246 # This option is used to create non-root users on your CD.  It takes a space
247 # separated list of user names.  These users will be added to the following
248 # groups: users,wheel,audio,games,cdrom,usb
249 # If this is specified in your spec file, then the first user is also the user
250 # used to start X. Since this is not used on the release media, it is blank.
251 # example:
252 # livecd/users:
253 livecd/users:
254
255 # This option sets the volume ID of the CD created.
256 # example:
257 # livecd/volid: Gentoo Linux 2006.1 X86
258 livecd/volid:
259
260 # This option is only used when creating a GameCD.  This specifies the file that
261 # contains the definitions for GAME_NAME and GAME_EXECUTABLE, which are used by
262 # the GameCD scripts to set some specific options for the game.  This is not
263 # used on the release media, and is therefore blank.
264 # example:
265 # gamecd/conf:
266 gamecd/conf:
267
268 # This option is used to specify the number of kernels to build and also the
269 # labels that will be used by the CD bootloader to refer to each kernel image.
270 # example:
271 # boot/kernel: gentoo
272 boot/kernel:
273
274 # This option tells catalyst which kernel sources to merge for this kernel
275 # label.  This can use normal portage atoms to specify a specific version.
276 # example:
277 # boot/kernel/gentoo/sources: gentoo-sources
278 boot/kernel/gentoo/sources:
279
280 # This option is the full path and filename to a kernel .config file that is
281 # used by genkernel to compile the kernel this label applies to.
282 # example:
283 # boot/kernel/gentoo/config: /tmp/2.6.11-smp.config
284 boot/kernel/gentoo/config:
285
286 # This option sets genkernel parameters on a per-kernel basis and applies only
287 # to this kernel label.  This can be used for building options into only a
288 # single kernel, where compatibility may be an issue.  Since we do not use this
289 # on the official release media, it is left blank, but it follows the same
290 # syntax as livecd/gk_mainargs.
291 # example:
292 # boot/kernel/gentoo/gk_kernargs:
293 boot/kernel/gentoo/gk_kernargs:
294
295 # This option sets the USE flags used to build the kernel and also any packages
296 # which are defined under this kernel label.  These USE flags are additive from
297 # the default USE for the specified profile.
298 # example:
299 # boot/kernel/gentoo/use: pcmcia usb -X
300 boot/kernel/gentoo/use:
301
302 # This option appends an extension to the name of your kernel, as viewed by a
303 # uname -r/  This also affects any modules built under this kernel label.  This
304 # is useful for having two kernels using the same sources to keep the modules
305 # from overwriting each other.  We do not use this on the official media, so it
306 # is left blank.
307 # example:
308 # boot/kernel/gentoo/extraversion:
309 boot/kernel/gentoo/extraversion:
310
311 # This option is for merging kernel-dependent packages and external modules that
312 # are configured against this kernel label.
313 # example:
314 # boot/kernel/gentoo/packages: pcmcia-cs speedtouch slmodem globespan-adsl hostap-driver hostap-utils ipw2100 ipw2200 fritzcapi fcdsl cryptsetup
315 boot/kernel/gentoo/packages:
316
317 # This option is only for ppc64 machines.  If used it will create the /etc/yaboot.conf
318 # entry used for booting a ibm powerpc machine.
319 # example:
320 # boot/kernel/gentoo/machine_type: ibm
321 boot/kernel/gentoo/machine_type:
322
323 # This is only supported on ppc64 currently.  This entry sets up the console=
324 # boot parameters required for sending the output to the appropriate console.
325 # example:
326 # boot/kernel/gentoo/console: hvsi0
327 # boot/kernel/gentoo/console: hvc0
328 # boot/kernel/gentoo/console: tty0 ttyS0
329 boot/kernel/gentoo/console:
330
331 # This is a list of packages that will be unmerged after all the kernels have
332 # been built.  There are no checks on these packages, so be careful what you
333 # add here.  They can potentially break your CD.
334 # example:
335 # livecd/unmerge: acl attr autoconf automake bin86 binutils libtool m4 bison ld.so make perl patch linux-headers man-pages sash bison flex gettext texinfo ccache distcc man groff lib-compat miscfiles rsync sysklogd bc lcms libmng genkernel diffutils libperl gnuconfig gcc-config gcc bin86 cpio cronbase ed expat grub lilo help2man libtool gentoo-sources
336 livecd/unmerge:
337
338 # This option is used to empty the directories listed.  It is useful for getting
339 # rid of files that don't belong to a particular package, or removing files from
340 # a package that you wish to keep, but won't need the full functionality.
341 # example:
342 # livecd/empty: /var/tmp /var/cache /var/db /var/empty /var/lock /var/log /var/run /var/spool /var/state /tmp /usr/portage /usr/share/man /usr/share/info /usr/share/unimaps /usr/include /usr/share/zoneinfo /usr/share/dict /usr/share/doc /usr/share/ss /usr/share/state /usr/share/texinfo /usr/lib/python2.2 /usr/lib/portage /usr/share/gettext /usr/share/i18n /usr/share/rfc /usr/lib/X11/config /usr/lib/X11/etc /usr/lib/X11/doc /usr/src /usr/share/doc /usr/share/man /root/.ccache /etc/cron.daily /etc/cron.hourly /etc/cron.monthly /etc/cron.weekly /etc/logrotate.d /etc/rsync /usr/lib/awk /usr/lib/ccache /usr/lib/gcc-config /usr/lib/nfs /usr/local /usr/diet/include /usr/diet/man /usr/share/consolefonts/partialfonts /usr/share/consoletrans /usr/share/emacs /usr/share/gcc-data /usr/share/genkernel /etc/bootsplash/gentoo /etc/bootsplash/gentoo-highquality /etc/splash/gentoo /etc/splash/emergence /usr/share/gnuconfig /usr/share/lcms /usr/share/locale /etc/skel
343 livecd/empty:
344
345 # This option tells catalyst to clean specific files from the filesystem and is
346 # very usefu in cleaning up stray files in /etc left over after livecd/unmerge.
347 # example:
348 # livecd/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/portage/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/bootsplash* /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2006.1/16* /etc/splash/livecd-2006.1/12* /etc/splash/livecd-2006.1/6* /etc/splash/livecd-2006.1/8* /etc/splash/livecd-2006.1/images/silent-16* /etc/splash/livecd-2006.1/images/silent-12* /etc/splash/livecd-2006.1/images/silent-6* /etc/splash/livecd-2006.1/images/silent-8* /etc/splash/livecd-2006.1/images/verbose-16* /etc/splash/livecd-2006.1/images/verbose-12* /etc/splash/livecd-2006.1/images/verbose-6* /etc/splash/livecd-2006.1/images/verbose-8* /etc/portage/make.conf.example /etc/make.globals /etc/resolv.conf
349 livecd/rm: