Changing link so it no longer points to a dead page. This is for bug #208609.
[catalyst.git] / examples / generic_stage_template.spec
1 # generic installation stage specfile
2 # used to build a stage1, stage2, or stage3 installation tarball
3
4 # The subarch can be any of the supported catalyst subarches (like athlon-xp).
5 # Refer to the catalyst reference manual for suppurted subarches.
6 # http://www.gentoo.org/proj/en/releng/catalyst/
7 # example:
8 # subarch: athlon-xp
9 subarch:
10
11 # The version stamp is an identifier for the build.  It can be anything you wish
12 # it to be, but it is usually a date.
13 # example:
14 # version_stamp: 2006.1
15 version_stamp: 
16
17 # The target specifies what target we want catalyst to do. For stages, the
18 # supported targets are: stage1 stage2 stage3
19 # example:
20 # target: stage2
21 target:
22
23 # The rel_type defines what kind of build we are doing.  This is merely another
24 # identifier, but it useful for allowing multiple concurrent builds.  Usually,
25 # default will suffice.
26 # example:
27 # rel_type: default
28 rel_type:
29
30 # This is the system profile to be used by catalyst to build this target.  It is
31 # specified as a relative path from /usr/portage/profiles.
32 # example:
33 # profile: default-linux/x86/2006.1
34 profile:
35
36 # This specifies which snapshot to use for building this target.
37 # example:
38 # snapshot: 2006.1
39 snapshot:
40
41 # This specifies where the seed stage comes from for this target,  The path is
42 # relative to $clst_sharedir/builds.  The rel_type is also used as a path prefix
43 # for the seed.
44 # example:
45 # default/stage3-x86-2006.1
46 source_subpath:
47
48 # These are the hosts used as distcc slaves when distcc is enabled in your 
49 # catalyst.conf.  It follows the same syntax as distcc-config --set-hosts and
50 # is entirely optional.
51 # example:
52 # distcc_hosts: 127.0.0.1 192.168.0.1
53 distcc_hosts:
54
55 # This is an optional directory containing portage configuration files.  It
56 # follows the same syntax as /etc/portage and should be consistent across all
57 # targets to minimize problems.
58 # example:
59 # portage_confdir: /etc/portage
60 portage_confdir:
61
62 # This option specifies the location to a portage overlay that you would like to
63 # have used when building this target.
64 # example:
65 # portage_overlay: /usr/local/portage
66 portage_overlay:
67
68 # This allows the optional directory containing the output packages for
69 # catalyst.  Mainly used as a way for different spec files to access the same
70 # cache directory.  Default behavior is for this location to be autogenerated
71 # by catalyst based on the spec file.
72 # example:
73 # pkgcache_path: /tmp/packages
74 pkgcache_path:
75
76 # These options are only available when building a stage1 or stage2 target and
77 # are all optional.  These allow for emulating the changes possible during ai
78 # bootstrap.  Some possible uses of these would be building embedded stages
79 # requiring a different CHOST or building a stage2 with NPTL support from a
80 # stage1 tarball that is built without it.
81 # If left blank, then the catalyst defaults from arch.py are used.
82
83 # This option is used to change the CHOST from what is default in the profile
84 # to whatever you specify.  This is useful for building NPTL, for example.
85 # example:
86 # chost: i686-pc-linux-gnu
87 chost:
88
89 # This option allows you to change the default CFLAGS that will be used in
90 # building this stage.  This really should remain generic, as putting
91 # optimizations flags here will build a stage1 tarball that is no longer
92 # generic.
93 # example:
94 # cflags: -Os -pipe -fomit-frame-pointer -mcpu=i686
95 cflags:
96
97 # This is for setting the CXXFLAGS.  Generally, this would be set to the same
98 # as CFLAGS.  In fact, it will mirror CFLAGS by default.
99 # example:
100 # cxxflags: -Os -pipe -fomit-frame-pointer -mcpu=i686
101 cxxflags:
102
103 # Setting this option sets LDFLAGS in make.conf in your stage.  This would be
104 # useful for setting up an embedded or hardened system.
105 # example:
106 # ldflags: -Wl,-O1 -Wl,-z,now
107 ldflags: