dev-python/warlock: 1.3.3 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 18 May 2020 03:12:16 +0000 (22:12 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 18 May 2020 03:12:30 +0000 (22:12 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/warlock/Manifest
dev-python/warlock/warlock-1.3.3.ebuild [new file with mode: 0644]

index 25985766e2c9843ab1ccdb5ed86511c19e96067d..185469bc9ebaeb755c70371b7f8f40008e466794 100644 (file)
@@ -1 +1,2 @@
 DIST warlock-1.3.0.tar.gz 8853 BLAKE2B 51b313f81cc7009b2b336d6ea7ecf5b78adfe33b3efee3abd9b2296f90716db25fcd4a06eb6946c26c3700ccf5d090da716bd4c5a7864f285e26bd2504700c3c SHA512 0c60c624e89782009a79a0174e6855a9d3a084403f5fa8fc676ad28c42184ff44c43684d6ab68262045f75588932ab4679dffb05f7762c290741ca645d90f32a
+DIST warlock-1.3.3.tar.gz 11602 BLAKE2B 8d3bd3cd19f27e9c4ceac97f242742c58c6687659d8ab0ea42da74ce948e43415e513e7d7269767b76b21c995229702da66c64688119bbfcc0d30e872af1b65e SHA512 b6f96aa8e084872397744641e3fdc0e7c8d0a9285b048e894b66ccb42af65301c550813221895f0f99ac49cc26d293798b731cdf30524c13a79389ce07dd7e44
diff --git a/dev-python/warlock/warlock-1.3.3.ebuild b/dev-python/warlock/warlock-1.3.3.ebuild
new file mode 100644 (file)
index 0000000..2202183
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python object model built on JSON schema and JSON patch"
+HOMEPAGE="https://github.com/bcwaldon/warlock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+               test? ( dev-python/six[${PYTHON_USEDEP}]
+                               >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
+                               <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
+                               >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
+                               <dev-python/jsonschema-4[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+               >=dev-python/jsonpatch-0.10[${PYTHON_USEDEP}]
+               <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
+               >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
+               <dev-python/jsonschema-4[${PYTHON_USEDEP}]"
+
+python_test() {
+       "${PYTHON}" test/test_core.py || die
+}