dev-python/picklemagic: fix Gentoo repo QA warnings
authorAndrew Savchenko <bircoph@gentoo.org>
Sun, 10 May 2020 13:03:51 +0000 (16:03 +0300)
committerAndrew Savchenko <bircoph@gentoo.org>
Sun, 10 May 2020 13:07:03 +0000 (16:07 +0300)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
dev-python/picklemagic/metadata.xml
dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild

index cea503d75e3ba401358f5de4b333fae0001166d7..1027055fe7b125dc4131c3a332f5885f8437a1e4 100644 (file)
@@ -7,6 +7,13 @@
        </maintainer>
        <longdescription>
                A set of modules for analyzing and playing with the mechanics of python pickles.
+               Features:
+                       * Forgiving: Extracts as much data as possible from the pickle, even if class definitions are unavailable.
+                       * Safe: You can safely unpickle data structures from unknown sources
+                       * Easy to use: Tools are provided which make it possible to code around the unpickled datastructures as if they were created from the actual class definitions.
+                       * Customizeable: Most functionality is easily subclassable to suit your needs.
+                       * Create pickles as if you were writing python: Via a few constructs it's possible to create custom pickles with the ease of writing normal python.
+                       * Works in both python 2 and 3
        </longdescription>
        <upstream>
                <remote-id type="github">CensoredUsername/picklemagic</remote-id>
index 983b5bc2640ee78764a3600d5c5337106e0ca065..66c0a794e6ba047634ac175470b172376212c1b0 100644 (file)
@@ -8,13 +8,16 @@ inherit python-r1
 
 SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
 KEYWORDS="~amd64 ~x86"
-DESCRIPTION="A library for analysing python pickles safely "
+DESCRIPTION="A library for analysing python pickles safely"
 HOMEPAGE="https://github.com/CensoredUsername/picklemagic"
 LICENSE="WTFPL-2"
 SLOT="0"
 IUSE="doc"
 
 BDEPEND="doc? ( dev-python/sphinx )"
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 src_compile() {
        use doc && emake -C doc html