app-benchmarks/bootchart2: Drop USE X, broken python deps, EAPI-7 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 30 Apr 2020 11:18:19 +0000 (13:18 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 30 Apr 2020 15:10:07 +0000 (17:10 +0200)
Also drop no-op USE svg.
Drop USE test that depend on X, restrict tests.
Don't compress manpages.

Closes: https://bugs.gentoo.org/708108
Closes: https://bugs.gentoo.org/718200
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-benchmarks/bootchart2/bootchart2-0.14.8-r1.ebuild [new file with mode: 0644]
app-benchmarks/bootchart2/files/bootchart2-0.14.8-no-compressed-man.patch [new file with mode: 0644]

diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.8-r1.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.8-r1.ebuild
new file mode 100644 (file)
index 0000000..6cb11cd
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="https://github.com/mmeeks/bootchart/"
+SRC_URI="https://github.com/mmeeks/bootchart/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+RDEPEND="
+       !app-benchmarks/bootchart
+       sys-apps/lsb-release"
+
+S="${WORKDIR}"/${PN%2}-${PV}
+
+CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.14.7-sysmacros.patch # bug 579922
+       "${FILESDIR}"/${P}-no-compressed-man.patch
+)
+
+src_prepare() {
+       default
+       tc-export CC
+       sed -i \
+               -e "/^install/s:py-install-compile::g" \
+               -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_systemunitdir):g" \
+               Makefile || die
+       sed -i \
+               -e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty:g' \
+               bootchartd.conf bootchartd.in || die
+}
+
+src_install() {
+       export DOCDIR=/usr/share/doc/${PF}
+       default
+
+       # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+       # just change it. Since no libraries are installed, /lib is fine.
+       keepdir /lib/bootchart/tmpfs
+
+       newinitd "${FILESDIR}"/${PN}.init ${PN}
+}
+
+pkg_postinst() {
+       elog "If you are using an initrd during boot"
+       elog "please add the init script to your default runlevel"
+       elog "rc-update add bootchart2 default"
+}
diff --git a/app-benchmarks/bootchart2/files/bootchart2-0.14.8-no-compressed-man.patch b/app-benchmarks/bootchart2/files/bootchart2-0.14.8-no-compressed-man.patch
new file mode 100644 (file)
index 0000000..261e821
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/Makefile 2015-12-17 09:12:57.000000000 +0100
++++ b/Makefile 2020-04-30 13:14:08.772369141 +0200
+@@ -107,9 +107,9 @@
+       install -m 644 -D README $(DESTDIR)$(DOCDIR)/README
+       install -m 644 -D README.pybootchart $(DESTDIR)$(DOCDIR)/README.pybootchart
+       mkdir -p $(DESTDIR)$(MANDIR)
+-      gzip -c bootchart2.1 > $(DESTDIR)$(MANDIR)/bootchart2.1.gz
+-      gzip -c bootchartd.1 > $(DESTDIR)$(MANDIR)/$(PROGRAM_PREFIX)bootchartd$(PROGRAM_SUFFIX).1.gz
+-      gzip -c pybootchartgui.1 > $(DESTDIR)$(MANDIR)/pybootchartgui.1.gz
++      install -m 644 bootchart2.1 $(DESTDIR)$(MANDIR)/bootchart2.1
++      install -m 644 bootchartd.1 $(DESTDIR)$(MANDIR)/$(PROGRAM_PREFIX)bootchartd$(PROGRAM_SUFFIX).1
++      install -m 644 pybootchartgui.1 $(DESTDIR)$(MANDIR)/pybootchartgui.1
+ install-service:
+       mkdir -p $(DESTDIR)$(SYSTEMD_UNIT_DIR)