x11-misc/pcmanfm-qt: add version 0.15.1
authorJimi Huotari <chiitoo@gentoo.org>
Mon, 27 Apr 2020 18:18:23 +0000 (21:18 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:33 +0000 (01:28 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
x11-misc/pcmanfm-qt/Manifest
x11-misc/pcmanfm-qt/pcmanfm-qt-0.15.1.ebuild [new file with mode: 0644]

index 280320d8d6dae5baed7d50f70f86d2a0e4985147..8cecd17ee890bedb66ab42392944899dc7f4edb5 100644 (file)
@@ -1 +1,2 @@
 DIST pcmanfm-qt-0.14.1.tar.xz 227360 BLAKE2B 2401238ad53838c9f6e45d596c43b09eecf555bfe069a5cef633c0442867f04b636bebf29241cae8b5a1161a9dad5648390badcd6a3d8b756ac6438acac4961f SHA512 f3d170ab8344332f740a3245cc549ea0c3bddc97a45472dcd46208d59413dd42d3571821f309184417a34a627d2cb093fcaa335f782cf6e526eef3fcad212b3e
+DIST pcmanfm-qt-0.15.1.tar.xz 257832 BLAKE2B 78c8f5723b529b7f8a00870f017818183a498d8a1f68f8f24ab756eeda9b35d8d998b42d87f78e4a8fb6725bf3e812dca74bc1464f285a6a984dae1996b43f46 SHA512 db0d3cc683b5c94cabab5a8c68b3ae8bf5938735b34989a420692e933bb54d53ebb15da9af4a59039bfd101de0cc00c521c08207e81bfad9d80315e2d94bc559
diff --git a/x11-misc/pcmanfm-qt/pcmanfm-qt-0.15.1.ebuild b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.15.1.ebuild
new file mode 100644 (file)
index 0000000..4852d01
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake eutils xdg-utils
+
+DESCRIPTION="Qt GUI Tabbed Filemanager"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ "${PV}" == "9999" ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+       >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+       dev-libs/glib:2
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       =x11-libs/libfm-qt-$(ver_cut 1-2)*
+       x11-libs/libxcb:=
+       x11-misc/xdg-utils
+       virtual/eject
+       virtual/freedesktop-icon-theme
+"
+RDEPEND="${DEPEND}
+       !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+       xdg_desktop_database_update
+
+       optfeature "mount password storing" gnome-base/gnome-keyring
+       ! has_version lxqt-base/lxqt-meta && optfeature "trash functionality" gnome-base/gvfs
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}