sys-auth/pam_ssh: fix build with gcc-10
authorMikle Kolyada <zlogene@gentoo.org>
Wed, 22 Apr 2020 12:24:21 +0000 (15:24 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 22 Apr 2020 12:26:21 +0000 (15:26 +0300)
Closes: https://bugs.gentoo.org/709312

Thanks-to: Jeroen Roovers <jer@gentoo.org>

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sys-auth/pam_ssh/files/pam_ssh-gcc10-fix.patch [new file with mode: 0644]
sys-auth/pam_ssh/pam_ssh-2.3.ebuild

diff --git a/sys-auth/pam_ssh/files/pam_ssh-gcc10-fix.patch b/sys-auth/pam_ssh/files/pam_ssh-gcc10-fix.patch
new file mode 100644 (file)
index 0000000..9871b42
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/ge25519.h
++++ b/ge25519.h
+@@ -28,7 +28,7 @@
+   fe25519 t;
+ } ge25519;
+-const ge25519 ge25519_base;
++extern const ge25519 ge25519_base;
+ int ge25519_unpackneg_vartime(ge25519 *r, const unsigned char p[32]);
index aa31b08e2c85b3e2730f86b697b7a2c3790b0446..23e4dd08095975e31150c895e3df1d5bc7a9b8aa 100644 (file)
@@ -12,17 +12,18 @@ SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.xz"
 LICENSE="BSD-2 BSD ISC"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
 
 # Only supports OpenSSH via `ssh-agent` #282993
 DEPEND="sys-libs/pam
        dev-libs/openssl:0="
+
 RDEPEND="${DEPEND}
        net-misc/openssh"
 
 PATCHES=(
        # 503424#c5
        "${FILESDIR}"/${PN}-2.1-dot-ssh-check.patch
+       "${FILESDIR}"/${PN}-gcc10-fix.patch
 )
 
 src_configure() {