games-arcade/xboing: Apply -fcommon workaround
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 24 Apr 2020 21:23:43 +0000 (00:23 +0300)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 24 Apr 2020 21:23:43 +0000 (00:23 +0300)
This is prehistoric software without upstream activity or even a
bugtracker. Let's keep it working as long as possible...

Closes: https://bugs.gentoo.org/707214
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
games-arcade/xboing/xboing-2.4-r3.ebuild

index 9c36b5a49e69a01a266cab0f1819298480f94403..d478242213478e29c86d1c4e949d9dcd838e1d01 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-inherit eutils
+inherit flag-o-matic eutils
 
 DESCRIPTION="Blockout type game where you bounce a ball trying to destroy blocks"
 HOMEPAGE="http://www.techrescue.org/xboing/"
@@ -36,6 +36,7 @@ src_prepare() {
 src_configure() {
        xmkmf -a || die
        sed -i -e "s:GENTOO_VER:${PF/${PN}-/}:" Imakefile || die
+       append-cflags -fcommon
 }
 
 src_compile() {