dev-util/ccls: Pass -DCLANG_LINK_CLANG_DYLIB=1
authorMatt Turner <mattst88@gentoo.org>
Sat, 25 Apr 2020 03:52:17 +0000 (20:52 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 25 Apr 2020 03:53:27 +0000 (20:53 -0700)
Fixes the build with clang-10, while evidently not harming the build
against earlier versions.

Thanks to Michael Cook for the patch.

Closes: https://bugs.gentoo.org/714764
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-util/ccls/ccls-0.20190823.6.ebuild
dev-util/ccls/ccls-9999.ebuild

index d959663fa6f0cdd19da78af08650bae91932c44b..ac5830184a31cd6c8374e41098e05cbf832c72d5 100644 (file)
@@ -35,6 +35,7 @@ RDEPEND="${DEPEND}"
 src_configure() {
        local mycmakeargs=(
                -DUSE_SYSTEM_RAPIDJSON=ON
+               -DCLANG_LINK_CLANG_DYLIB=1
        )
        cmake_src_configure
 }
index d959663fa6f0cdd19da78af08650bae91932c44b..ac5830184a31cd6c8374e41098e05cbf832c72d5 100644 (file)
@@ -35,6 +35,7 @@ RDEPEND="${DEPEND}"
 src_configure() {
        local mycmakeargs=(
                -DUSE_SYSTEM_RAPIDJSON=ON
+               -DCLANG_LINK_CLANG_DYLIB=1
        )
        cmake_src_configure
 }