games-board/four-in-a-row: bump to 3.34.4
authorMart Raudsepp <leio@gentoo.org>
Sun, 22 Mar 2020 15:07:15 +0000 (17:07 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 22 Mar 2020 15:21:30 +0000 (17:21 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
games-board/four-in-a-row/Manifest
games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild [new file with mode: 0644]

index 849df408cc261fd4a2396558a4a7d3bab61b0313..1bf0c3a3f8230e788d0b2ca4d85aebc3f905203f 100644 (file)
@@ -1 +1,2 @@
 DIST four-in-a-row-3.32.0.tar.xz 507596 BLAKE2B 8253c1f44d7c3e27d2e3fe64984aff5485569496d85a77a48b2fd67fee065377f4667b92524481838787c0b7f27e16250b0aa1bc53ff470624f9da92187b7e44 SHA512 f74dcb072c4da03b8cfc274d92a0eda8ca1fbea4b216b4add793155ae63bd8cc1c784ea2b553a198616dbc2254bb1d5567ddc1608f027eaf6e0a594741a2ab96
+DIST four-in-a-row-3.34.4.tar.xz 508780 BLAKE2B 4528642e82438c52706d068d01f5d167f83f4b6dc0a9883bd95a046d9c9772ac642f27f0b1b1197a4ce81b3b5a5a14ce7f9ed8eacbaca189692c0a3c34faeda1 SHA512 7bdfbf1c8953175af8dccbe0514215349a48246f949723628a940db6e5b1e3d89990aa57b5994e5460a79db19ba207de939fe81da53d5782a762695d1588776f
diff --git a/games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild b/games-board/four-in-a-row/four-in-a-row-3.34.4.ebuild
new file mode 100644 (file)
index 0000000..3dd8ca7
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row"
+
+# Code and most themes are GPL-3+, CC-BY-SA-3.0 is user help license in v3.32.0
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-libs/glib-2.40.0:2
+       >=media-libs/gsound-1.0.2
+       >=x11-libs/gtk+-3.13.2:3
+       >=gnome-base/librsvg-2.32.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-libs/appstream-glib
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       $(vala_depend)
+       media-libs/gsound[vala]
+       gnome-base/librsvg[vala]
+"
+
+src_prepare() {
+       xdg_src_prepare
+       vala_src_prepare
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}