sys-apps/hd-idle: Bump to EAPI 7, add systemd service.
authorOliver Freyermuth <o.freyermuth@googlemail.com>
Sun, 3 May 2020 20:36:40 +0000 (22:36 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 5 May 2020 08:46:36 +0000 (11:46 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Closes: https://github.com/gentoo/gentoo/pull/15634
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-apps/hd-idle/files/hd-idle-service [new file with mode: 0644]
sys-apps/hd-idle/hd-idle-1.05-r1.ebuild [new file with mode: 0644]

diff --git a/sys-apps/hd-idle/files/hd-idle-service b/sys-apps/hd-idle/files/hd-idle-service
new file mode 100644 (file)
index 0000000..f69c1d7
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+[Unit]
+Description=hd-idle - spinning down HDDs after a period of idle time
+Documentation=man:hd-idle(1)
+
+[Service]
+Type=forking
+EnvironmentFile=/etc/conf.d/hd-idle
+ExecStart=/usr/sbin/hd-idle $HD_IDLE_OPTS
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/hd-idle/hd-idle-1.05-r1.ebuild b/sys-apps/hd-idle/hd-idle-1.05-r1.ebuild
new file mode 100644 (file)
index 0000000..2700e28
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Utility for spinning down hard disks after a period of idle time"
+HOMEPAGE="http://hd-idle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+CONFIG_CHECK="~PROC_FS"
+
+DOCS=( debian/changelog README )
+
+src_install() {
+       default
+       systemd_newunit "${FILESDIR}"/hd-idle-service ${PN}.service
+       newinitd "${FILESDIR}"/hd-idle-init hd-idle
+       newconfd "${FILESDIR}"/hd-idle-conf hd-idle
+}