games-util/lgogdownloader: add live version
authorsoredake <fdsfgs@krutt.org>
Wed, 8 Nov 2017 13:54:48 +0000 (15:54 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Thu, 9 Nov 2017 20:16:26 +0000 (20:16 +0000)
Closes: https://github.com/gentoo/gentoo/pull/6149

games-util/lgogdownloader/lgogdownloader-9999.ebuild [new file with mode: 0644]

diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
new file mode 100644 (file)
index 0000000..478ab0e
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="+debug"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+       dev-cpp/htmlcxx:0=
+       dev-libs/boost:0=
+       >=dev-libs/jsoncpp-1.7:0=
+       dev-libs/tinyxml2:0=
+       net-libs/liboauth:0=
+       >=net-misc/curl-7.32:0=[ssl]"
+
+DEPEND="${RDEPEND}
+       sys-apps/help2man
+       virtual/pkgconfig"