sys-libs/ncurses: Fix broken use of ROOT=/ has_version under EAPI 7
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 8 Jun 2019 22:24:36 +0000 (23:24 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 8 Jun 2019 22:24:36 +0000 (23:24 +0100)
Pass -b instead as changing ROOT confuses Portage to the point where
this breaks when building for a ROOTed cross-prefix environment.

Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
sys-libs/ncurses/ncurses-6.1_p20181020.ebuild

index c96c376e5c8e51f39741f3bd8d2ceb0d91f423f5..ba84afddf044aa0b8596922ad1863a62503e6174 100644 (file)
@@ -70,7 +70,7 @@ src_configure() {
        # This comes up when cross-compiling, doing multilib builds, upgrading,
        # or installing for the first time.  Build a local copy of tic whenever
        # the host version isn't available. #249363 #557598
-       if ! ROOT=/ has_version "~sys-libs/${P}:0" ; then
+       if ! has_version -b "~sys-libs/${P}:0" ; then
                local lbuildflags="-static"
 
                # some toolchains don't quite support static linking
@@ -192,7 +192,7 @@ do_configure() {
 
 src_compile() {
        # See comments in src_configure.
-       if ! ROOT=/ has_version "~sys-libs/${P}:0" ; then
+       if ! has_version -b "~sys-libs/${P}:0" ; then
                BUILD_DIR="${WORKDIR}" \
                do_compile cross -C progs tic
        fi