dev-python/argcomplete: Require non-ancient dev-python/pip for tests
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 19:50:15 +0000 (21:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 19:50:35 +0000 (21:50 +0200)
Tests fail with pip-9, so require >=19.  Sadly, this means rekeywording.

Closes: https://bugs.gentoo.org/709944
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild b/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
new file mode 100644 (file)
index 0000000..47957f5
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="https://pypi.org/project/argcomplete/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       $(python_gen_cond_dep '
+               <dev-python/importlib_metadata-2[${PYTHON_USEDEP}]
+       ' -2 python3_{5,6,7} pypy3)"
+# pip is called as an external tool
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               app-shells/fish
+               app-shells/tcsh
+               dev-python/pexpect[${PYTHON_USEDEP}]
+               >=dev-python/pip-19
+       )"
+
+python_test() {
+       "${EPYTHON}" test/test.py -v || die
+}