x11-wm/wmfs: Respect CFLAGS/LDFLAGS, fix man page
authorJeroen Roovers <jer@gentoo.org>
Sun, 17 May 2020 13:38:49 +0000 (15:38 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 17 May 2020 13:41:49 +0000 (15:41 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Bug: https://bugs.gentoo.org/706654
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-wm/wmfs/wmfs-201003.ebuild

index 14da5d0b915896cf4b10a2dfbc1e1b32c52a2bf5..27bdfa3ef564d605ffce197ad2f1bb22cf080860 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit cmake-utils eutils
+EAPI=7
+inherit cmake
 
 DESCRIPTION="Window Manager From Scratch, A tiling window manager highly configurable"
 HOMEPAGE="https://github.com/xorg62/wmfs"
@@ -31,8 +31,17 @@ PATCHES=(
        "${FILESDIR}"/${PN}-201003-pthread.patch
 )
 
+src_prepare() {
+       cmake_src_prepare
+       sed -i \
+               -e '/set(CFLAGS/d' \
+               -e '/set(LDFLAGS/s#)# ${LDFLAGS}&#' \
+               CMakeLists.txt || die
+}
+
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        rm -r "${D}"/usr/share/${PN}
+       find "${D}"/usr/share/man -name '*.gz' -exec gunzip {} \; || die
        dodoc README TODO rc/status.sh
 }