sys-process/uksmd: 2020-05-04 snapshot
authorJoonas Niilola <juippis@gentoo.org>
Wed, 6 May 2020 05:02:44 +0000 (08:02 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 6 May 2020 05:03:20 +0000 (08:03 +0300)
Bug: https://bugs.gentoo.org/719896
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-process/uksmd/Manifest
sys-process/uksmd/files/uksmd-0_pre20200504-respect-cflags-ldflags.patch [new file with mode: 0644]
sys-process/uksmd/uksmd-0_pre20200504.ebuild [new file with mode: 0644]

index 87667c6b87262df4ada0e90e1df9e5e04294046f..009da647990f287622bd23823587f5966522c6ae 100644 (file)
@@ -1 +1,2 @@
 DIST uksmd-0_pre20200420.tar.bz2 13464 BLAKE2B 717bb4c54ce3d56ec89ff08e0a60ff3e1f2f260c3e63f7821842f7c1216aeee4efb1cad693db4f9c03000dbde7c47b880356f175cb35b9c3861f3511090e4f32 SHA512 ed1d44c41f2f8731d1dad8a13c17cf412a6f735a68087969cb667f85945705b93ac716f010aae24825c0b32d43c38dad5661c7a36fc59fa89d553471d806d1ee
+DIST uksmd-0_pre20200504.tar.bz2 13919 BLAKE2B abda5df86a2592f2e1299f23a94389c7c4af36a37e38e9f618860b5ce0b7fc796eb3b0f248bda7e3522643f5d3a3219fd5d1c66e5a21f32f8bda2a6942f6339b SHA512 9b69b3fea603aab2af27a3542e6b217de31c227581779602ae67d352917e79626530fd6ad769a8a7c147f2883926458757fbca7502b4034550292c7e6e14f2f0
diff --git a/sys-process/uksmd/files/uksmd-0_pre20200504-respect-cflags-ldflags.patch b/sys-process/uksmd/files/uksmd-0_pre20200504-respect-cflags-ldflags.patch
new file mode 100644 (file)
index 0000000..407198d
--- /dev/null
@@ -0,0 +1,15 @@
+diff -Naur a/Makefile b/Makefile
+--- a/Makefile 2019-05-19 16:36:31.000000000 +0300
++++ b/Makefile 2019-07-24 18:12:29.444896030 +0300
+@@ -1,8 +1,8 @@
+ PROG = uksmd
+ OBJS = uksmd.o
+-PREFIX ?= /usr/local
+-CFLAGS = -O3 -Wall -Wextra -pedantic -pipe -fstack-protector-strong -fno-plt
+-LDFLAGS = -lprocps -lcap-ng
++PREFIX ?= /usr
++CFLAGS += -Wextra -pedantic -fstack-protector-strong -fno-plt
++LDFLAGS += -lprocps -lcap-ng
+ all: build
diff --git a/sys-process/uksmd/uksmd-0_pre20200504.ebuild b/sys-process/uksmd/uksmd-0_pre20200504.ebuild
new file mode 100644 (file)
index 0000000..4b45136
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+MY_COMMIT="5325ae51733ebb010862365c5a474f0d68f1ca1f"
+MY_P="${PN}-${MY_COMMIT}"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://gitlab.com/post-factum/uksmd"
+SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/libcap-ng
+       sys-process/procps:="
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/uksmd-0_pre20200504-respect-cflags-ldflags.patch" )
+
+src_install() {
+       default
+       einstalldocs
+
+       newinitd "${FILESDIR}/uksmd.init" uksmd
+       systemd_dounit distro/uksmd.service
+}