sys-process/uksmd: 2020-04-20 snapshot
authorJoonas Niilola <juippis@gentoo.org>
Mon, 27 Apr 2020 14:36:40 +0000 (17:36 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 27 Apr 2020 14:56:46 +0000 (17:56 +0300)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-process/uksmd/Manifest
sys-process/uksmd/uksmd-0_pre20200420.ebuild [new file with mode: 0644]

index 62b393ac65dd6e0ba3e04e7e6ad84226ac404f13..02cadc21c89849e8079d2616e3a935ff6023c53f 100644 (file)
@@ -1 +1,2 @@
 DIST uksmd-0_pre20190726.tar.bz2 13445 BLAKE2B 4d16b9e7dff80269561c61cf8ea4177e6ceaa2540a3ee5bb3a36684e8364d0a4abdfb494fd0dbb3e6d5d2c074601a0c39f9f0570448e3d5769e50184c8ef7975 SHA512 812217a067c2fe70a17a321b507071f369efa38ca12d566cde66b1fc6e2e3ffa7e4d3fd3904f2f3cf409e313d03ab06829cef23fffadd785282cb602dbd5f06e
+DIST uksmd-0_pre20200420.tar.bz2 13464 BLAKE2B 717bb4c54ce3d56ec89ff08e0a60ff3e1f2f260c3e63f7821842f7c1216aeee4efb1cad693db4f9c03000dbde7c47b880356f175cb35b9c3861f3511090e4f32 SHA512 ed1d44c41f2f8731d1dad8a13c17cf412a6f735a68087969cb667f85945705b93ac716f010aae24825c0b32d43c38dad5661c7a36fc59fa89d553471d806d1ee
diff --git a/sys-process/uksmd/uksmd-0_pre20200420.ebuild b/sys-process/uksmd/uksmd-0_pre20200420.ebuild
new file mode 100644 (file)
index 0000000..c90b24e
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+MY_COMMIT="9b6a6e55e07c524ba0a36eb25c869b47655010ee"
+MY_P="${PN}-${MY_COMMIT}"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://gitlab.com/post-factum/uksmd"
+SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-process/procps:="
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/uksmd-0_pre20190726-respect-cflags-ldflags.patch" )
+
+src_install() {
+       default
+       einstalldocs
+
+       newinitd "${FILESDIR}/uksmd.init" uksmd
+       systemd_dounit distro/uksmd.service
+}