app-editors/fe: Call tc-getAR to determine the ar program.
authorUlrich Müller <ulm@gentoo.org>
Sun, 10 May 2020 09:57:56 +0000 (11:57 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sun, 10 May 2020 10:24:00 +0000 (12:24 +0200)
Closes: https://bugs.gentoo.org/722036
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-editors/fe/fe-2.0.ebuild
app-editors/fe/files/fe-2.0-ar.patch [new file with mode: 0644]

index ca6658d94079037deee9f7c878282e82da58b817..207e9ec3f77332b95487fdace95a9be831b70e00 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -19,7 +19,10 @@ RDEPEND="sys-libs/ncurses:0=
 DEPEND="${RDEPEND}"
 BDEPEND="virtual/pkgconfig"
 
-PATCHES=("${FILESDIR}"/${PN}-1.8-makefile.patch)
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.8-makefile.patch
+       "${FILESDIR}"/${P}-ar.patch
+)
 
 src_configure() {
        econf \
@@ -27,6 +30,10 @@ src_configure() {
                LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
 }
 
+src_compile() {
+       emake AR="$(tc-getAR)"
+}
+
 src_install() {
        emake \
                prefix="${D}"/usr \
diff --git a/app-editors/fe/files/fe-2.0-ar.patch b/app-editors/fe/files/fe-2.0-ar.patch
new file mode 100644 (file)
index 0000000..8096400
--- /dev/null
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/722036
+
+--- fe-2.0-orig/Makefile.in
++++ fe-2.0/Makefile.in
+@@ -15,6 +15,7 @@
+ CPPFLAGS=     @CPPFLAGS@ -DLOCALEDIR=\"$(localedir)\"
+ LDFLAGS=      @LDFLAGS@
+ LIBS=         @LIBS@
++AR=           ar
+ CATALOGS=     de.mo
+ OBJS=         buffer.o complete.o display.o macro.o misc.o msgline.o
+@@ -27,7 +28,7 @@
+               $(CC) -o $@ $(LDFLAGS) fe.o libfe.a $(LIBS)
+ libfe.a:      $(OBJS)
+-              rm -f $@; ar q $@ $(OBJS); @RANLIB@ $@
++              rm -f $@; $(AR) q $@ $(OBJS); @RANLIB@ $@
+ install-po:   install-po-@USE_NLS@
+ install-po-no: