dev-perl/CGI-Simple: Bump to version 1.250.0
authorKent Fredric <kentnl@gentoo.org>
Thu, 7 May 2020 11:27:25 +0000 (23:27 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 7 May 2020 11:28:27 +0000 (23:28 +1200)
- EAPI7
- Fix license as best I can re bug #721422
- Parallel tests
- Remove empty variable assignments and useless/no longer needed
  variables/logic.

Upstream:
- Don't attempt to decode PUTDATA or POSTDATA if utf8 or NO_NULL is set
- Add SameSite support to Cookie handling
- Fix handling of max-age attribute in constructor
- Correct string value of "Found" for 302 responses as per RFC 2616
- Avoid warnings in STORE
- Add samesite parameter to ->cookie(...)

Bug: https://bugs.gentoo.org/721422
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild [new file with mode: 0644]
dev-perl/CGI-Simple/Manifest

diff --git a/dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild b/dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild
new file mode 100644 (file)
index 0000000..99f89b0
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=1.25
+inherit perl-module
+
+DESCRIPTION="A Simple totally OO CGI interface that is CGI.pm compliant"
+# Bug: https://bugs.gentoo.org/721422
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       dev-perl/Module-Build
+"
+BDEPEND="
+       dev-perl/Module-Build
+       test? (
+               dev-perl/libwww-perl
+               dev-perl/IO-stringy
+               virtual/perl-File-Temp
+               dev-perl/Test-Exception
+               dev-perl/Test-NoWarnings
+       )
+"
index 63bcb6ba4283ebad05e358698c2bd1d4b555288d..761348476e51225eb783812a027fa42e07059963 100644 (file)
@@ -1 +1,2 @@
 DIST CGI-Simple-1.115.tar.gz 85165 BLAKE2B 5b5fd1ecd7a4f8ef6ba17b9bb5de9ab058d7bb25fddac8e48d69afc8e117cfed08d3f02582b499c91329fb99d958b1f5bf32a83f826fa2a9d66f010563c646ac SHA512 1b2531fde88c4544d17717fd80599fcc4e90a618839c352d1812ba2bf4dd6c3295637d6fe5f9604cb5da943f0d361972b75083c5967b3ab818254729793751e4
+DIST CGI-Simple-1.25.tar.gz 87489 BLAKE2B 18ee59c7d97b042fdccaf93a9aa7a7aeafe6cdca52c675af11913a4cdb67daddf086679777936e3914663521c62a86795778b563478ed633d9b2b860a62fffb7 SHA512 ace262b4ccafe2ee01582aacf52b31aa1202dc5408bb33071330bc7c53f2cfbb39f9e8844c4511c86125dc05f7161b7592a4038c353dddd1bfd52c03dbcfa9dd