gnome-base/gnome-settings-daemon: fix USE="input_devices_wacom -wayland" build
authorMart Raudsepp <leio@gentoo.org>
Mon, 24 Feb 2020 21:03:32 +0000 (23:03 +0200)
committerMart Raudsepp <leio@gentoo.org>
Mon, 24 Feb 2020 21:04:55 +0000 (23:04 +0200)
Closes: https://bugs.gentoo.org/677494
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-base/gnome-settings-daemon/files/3.32.1-fix-wacom-no-wayland.patch [new file with mode: 0644]
gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.32.1-r1.ebuild

diff --git a/gnome-base/gnome-settings-daemon/files/3.32.1-fix-wacom-no-wayland.patch b/gnome-base/gnome-settings-daemon/files/3.32.1-fix-wacom-no-wayland.patch
new file mode 100644 (file)
index 0000000..ea343c4
--- /dev/null
@@ -0,0 +1,25 @@
+From ec6982cc8b3fccc35dbd5df3c4e22ab94709c66d Mon Sep 17 00:00:00 2001
+From: Vlad Banea <vlb@xiphos.ca>
+Date: Tue, 31 Dec 2019 15:35:41 -0500
+Subject: [PATCH] plugins/wacom: Fix build without WAYLAND
+
+---
+ plugins/wacom/gsd-wacom-manager.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plugins/wacom/gsd-wacom-manager.c b/plugins/wacom/gsd-wacom-manager.c
+index e1c8eaa7..92fd96c3 100644
+--- a/plugins/wacom/gsd-wacom-manager.c
++++ b/plugins/wacom/gsd-wacom-manager.c
+@@ -190,7 +190,7 @@ gsd_wacom_manager_class_init (GsdWacomManagerClass *klass)
+ static gchar *
+ get_device_path (GdkDevice *device)
+ {
+-#ifdef HAVE_WAYLAND
++#if HAVE_WAYLAND
+         if (gnome_settings_is_wayland ())
+                 return g_strdup (gdk_wayland_device_get_node_path (device));
+         else
+-- 
+2.20.1
+
index ae8ba7216b15160e8f652b983a6bd7ecf8558339..10a45fa6a23cb8f7a7f2be74d53bd94d345498eb 100644 (file)
@@ -85,6 +85,7 @@ PATCHES=(
        # Allow disabling udev and networkmanager on Linux
        # Make colord and wacom optional
        "${WORKDIR}"/patches/
+       "${FILESDIR}"/${PV}-fix-wacom-no-wayland.patch #677494, fixed in 3.36
 )
 
 python_check_deps() {