dev-libs/libpeas: fix python:3.8 compatibility
[gentoo.git] / dev-libs / libpeas / libpeas-1.22.0-r2.ebuild
similarity index 93%
rename from dev-libs/libpeas/libpeas-1.22.0-r1.ebuild
rename to dev-libs/libpeas/libpeas-1.22.0-r2.ebuild
index d2eec7dc5313016484ff4bbc7a4f61d6e0eda573..9918e9e75b87e8ca7e3c82079675bc5e99e25d8e 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=6
 GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
 PYTHON_COMPAT=( python{3_6,3_7,3_8} )
 
 inherit autotools eutils gnome2 multilib python-single-r1 virtualx
@@ -44,17 +45,16 @@ DEPEND="${RDEPEND}
 "
 # eautoreconf needs gobject-introspection-common, gnome-common
 
+PATCHES=(
+       # Gentoo uses unversioned lua - lua.pc instad of lua5.1.pc, /usr/bin/lua instead of /usr/bin/lua5.1
+       "${FILESDIR}"/${PN}-1.14.0-lua.pc.patch
+       "${FILESDIR}"/${PV}-py38-support.patch # Fix py3.8 support, bug 702810
+)
+
 pkg_setup() {
        use python && python-single-r1_pkg_setup
 }
 
-src_prepare() {
-       # Gentoo uses unversioned lua - lua.pc instad of lua5.1.pc, /usr/bin/lua instead of /usr/bin/lua5.1
-       eapply "${FILESDIR}"/${PN}-1.14.0-lua.pc.patch
-       eautoreconf
-       gnome2_src_prepare
-}
-
 src_configure() {
        # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
        # What do we do about gdb, valgrind, gcov, etc?