x11-terms/kitty-terminfo: split live ebuild
[gentoo.git] / x11-terms / kitty-terminfo / kitty-terminfo-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit python-any-r1 toolchain-funcs xdg git-r3
9
10 DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
11 HOMEPAGE="https://github.com/kovidgoyal/kitty"
12 EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 IUSE="debug"
17
18 DEPEND="${PYTHON_DEPS}"
19
20 PATCHES=(
21         "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
22 )
23
24 # kitty-terminfo is a split package from kitty that only installs the terminfo
25 # file. As tests are designed to be run with the whole package compiled they
26 # would fail in this case.
27 RESTRICT="test"
28
29 src_compile() {
30         "${EPYTHON}" setup.py \
31                 --verbose $(usex debug --debug "") \
32                 --libdir-name $(get_libdir) \
33                 linux-terminfo || die "Failed to compile kitty."
34 }
35
36 src_install() {
37         insinto /usr
38         doins -r linux-package/*
39 }