x11-misc/xwallpaper: bump to 0.6.5
[gentoo.git] / x11-misc / xkbset / xkbset-0.5_p6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils toolchain-funcs versionator
6
7 DEBIAN_P_MAJOR=$(get_version_component_range 3)
8 DEBIAN_P_MAJOR=${DEBIAN_P_MAJOR/p/}
9
10 DESCRIPTION="User preference utility for XKB extensions for X"
11 HOMEPAGE="https://faculty.missouri.edu/~stephen/software/#xkbset"
12 SRC_URI="
13         https://faculty.missouri.edu/~stephen/software/${PN}/${P/_p*/}.tar.gz
14         mirror://debian/pool/main/x/${PN}/${PN}_${PV/_p*/}-${DEBIAN_P_MAJOR}.debian.tar.xz
15 "
16
17 LICENSE="BSD"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="tk"
21
22 CDEPEND="
23         x11-libs/libX11
24 "
25 DEPEND="
26         ${CDEPEND}
27 "
28 RDEPEND="
29         ${CDEPEND}
30         tk? ( dev-perl/Tk )
31 "
32
33 S=${WORKDIR}/${P/_p*/}
34
35 PATCHES=(
36         "${FILESDIR}"/${P/_p*/}-ldflags.patch
37         "${WORKDIR}"/debian/patches/02-clarify-errors.patch
38 )
39
40 src_compile() {
41         emake CC=$(tc-getCC) INC_PATH= LIB_PATH=
42 }
43
44 src_install() {
45         dobin xkbset
46         use tk && dobin xkbset-gui
47         doman xkbset.1
48         dodoc README TODO
49 }